Bug 146300 - Syslog restart in update 4 reported as failure.
Syslog restart in update 4 reported as failure.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysklogd (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 15:04 EST by Michael Stahnke
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:08:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stahnke 2005-01-26 15:04:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When restarting syslog via a "service syslog restart" command, the
system reports syslog as a failure to restart. 

[root@xxx root]# service syslog restart
Shutting down kernel logger:                               [  OK  ]
Shutting down system logger:                               [  OK  ]
Starting system logger:                                    [FAILED]
Starting kernel logger:                                    [  OK  ]
[root@xxx root]#

The problem appears to be in this line of /etc/init.d/syslog

 [ $RETVAL -eq 0 ] && touch /var/lock/subsys/syslog

The $RETVAL can' be 0, so it can't touch /var/lock/subsys/syslog.





Version-Release number of selected component (if applicable):
initscripts-7.31.18.EL-1

How reproducible:
Always

Steps to Reproduce:
1.  Upgrade to update 4 ES3. 
2.    Service syslog restart
3.   Watch it say failed.  (system is actually logging)
    

Actual Results:   Watch it say failed.  (system is actually logging)

Expected Results:  [   OK   ]


Additional info:

I don't have much other information, though I have seen this on at
least 5 different machines.   The problem could be in the function in
/etc/init.d/functions.
Comment 1 Jason Vas Dias 2005-01-26 17:45:13 EST
Do the machines on which it failed have multiple CPUs ?

You are using sysklogd-1.4.1-12.3 (rpm -q sysklogd) ?

If so, I think this is a duplicate of bug 126223, which was fixed with
sysklogd-1.4.1-22 .

There was a race condition where syslogd's initial child could send
SIGTERM to the parent before the parent had installed its SIGTERM
handler - this handler tells the parent that the child is running OK -
so the parent gets SIGTERM and exits with an error, producing the 
[ FAILED ] message, but the child is actually running OK .

The latest version of syslogd is sysklogd-1.4.1-26_EL3, which is 
currently undergoing QA testing and should be in RHEL-3-U5.

Meanwhile, you can download from:
  http://people.redhat.com/~jvdias/sysklogd/RHEL-3

Please try this version - I think it should fix your problem.
Comment 2 Peter Vrabec 2007-01-29 15:46:14 EST
Does the problem still exist?
Comment 3 RHEL Product and Program Management 2007-10-19 15:08:34 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.