Bug 1463081 - [3.6] Running logging deployer with openshift_logging_es_pvc_dynamic=false still creates a dynamic pvc
[3.6] Running logging deployer with openshift_logging_es_pvc_dynamic=false st...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.6.z
Assigned To: ewolinet
Xia Zhao
: NeedsTestCase
Depends On:
Blocks: 1525431
  Show dependency treegraph
 
Reported: 2017-06-20 02:02 EDT by Mike Fiedler
Modified: 2017-12-13 05:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When conditions for creating pvcs within the logging role were incorrect. Consequence: dynamic pvcs were created even if they were explicitly set as 'false' for generating them. Fix: Updated the when conditions within the logging role Result: We correctly do not create dynamic pvcs
Story Points: ---
Clone Of:
: 1525431 (view as bug list)
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Fiedler 2017-06-20 02:02:51 EDT
Description of problem:

Running the openshift-logging.yaml deployer with openshift_logging_es_pvc_dynamic=false specified still results in the creation of a dynamic pvc.


Version-Release number of selected component (if applicable): 3.6.116 and openshift-ansible master HEAD dfd8232ec9284c0207edad62d8cb65adee07ccd3


How reproducible: Always if logging_es_pvc_dynamic=false is specified


Steps to Reproduce:
1.  Create an inventory with logging_es_pvc_dynamic=false (see below)
2.  Run byo/openshift-cluster/openshift-logging.yaml
3.  oc get pvc -n logging

Actual results:

NAME           STATUS    VOLUME    CAPACITY   ACCESSMODES   STORAGECLASS   AGE
logging-es-0   Pending                                      dynamic        3h


Expected results:

pvc is non-dynamic and uses available pv

Additional info:

[oo_first_master:vars]
openshift_deployment_type=openshift-enterprise
openshift_release=v3.6.0

openshift_logging_install_logging=true
openshift_logging_use_ops=false
openshift_logging_master_url=https://ec2-34-209-212-239.us-west-2.compute.amazonaws.com:8443
openshift_logging_master_public_url=https://ec2-34-209-212-239.us-west-2.compute.amazonaws.com:8443
openshift_logging_kibana_hostname=kibana.example.com
openshift_logging_namespace=logging
openshift_logging_image_prefix=registry.ops.openshift.com/openshift3/
openshift_logging_image_version=v3.6.116
openshift_logging_es_pvc_dynamic=false
openshift_logging_es_pvc_size=50Gi
openshift_logging_fluentd_use_journal=true
openshift_logging_es_pv_selector=None
Comment 1 ewolinet 2017-07-20 18:45:00 EDT
Can you please provide the output of oc get pvc/logging-es-0 -n logging -o yaml?
We should be setting the storageClass to "" if the pvc is not dynamic...
Comment 3 Mike Fiedler 2017-07-21 12:12:38 EDT
Logging/OpenShift/openshift-ansible all at 3.6.153.

Using the inventory above, the install no longer creates the dynamic pvc/pv.  However it also does not create the non-dynamic pvc for loggin-es-0

I expected 1 pvc to be created for size=50Gi.

root@ip-172-31-52-182: ~ # oc get all
NAME                                 REVISION   DESIRED   CURRENT   TRIGGERED BY
dc/logging-curator                   1          1         1         config
dc/logging-es-data-master-grr0qee6   1          1         1         config
dc/logging-kibana                    1          1         1         config

NAME                                   DESIRED   CURRENT   READY     AGE
rc/logging-curator-1                   1         1         1         58m
rc/logging-es-data-master-grr0qee6-1   1         1         1         59m
rc/logging-kibana-1                    1         1         1         59m

NAME                    HOST/PORT                        PATH      SERVICES         PORT      TERMINATION          WILDCARD
routes/logging-kibana   kibana.0712-6sq.qe.rhcloud.com             logging-kibana   <all>     reencrypt/Redirect   None

NAME                     CLUSTER-IP      EXTERNAL-IP   PORT(S)    AGE
svc/logging-es           172.27.28.101   <none>        9200/TCP   59m
svc/logging-es-cluster   172.25.42.181   <none>        9300/TCP   59m
svc/logging-kibana       172.27.185.39   <none>        443/TCP    59m

NAME                                         READY     STATUS    RESTARTS   AGE
po/logging-curator-1-11pkt                   1/1       Running   0          58m
po/logging-es-data-master-grr0qee6-1-nsr7b   1/1       Running   0          59m
po/logging-fluentd-12nn8                     1/1       Running   0          58m
po/logging-fluentd-2krbj                     1/1       Running   0          58m
po/logging-fluentd-h1x46                     1/1       Running   0          58m
po/logging-fluentd-vwbqm                     1/1       Running   0          58m
po/logging-kibana-1-g53wz                    2/2       Running   0          59m
root@ip-172-31-52-182: ~ # oc get pv
No resources found.
root@ip-172-31-52-182: ~ # oc get pvc
No resources found.



Exact inventory:


[oo_first_master]
ip-172-31-52-182

[oo_first_master:vars]
openshift_deployment_type=openshift-enterprise
openshift_release=v3.6.0

openshift_logging_install_logging=true
openshift_logging_use_ops=false
openshift_logging_master_url=https://ip-172-31-52-182:8443
openshift_logging_master_public_url=https://https://ec2-54-244-78-52.us-west-2.compute.amazonaws.com:8443
openshift_logging_kibana_hostname=kibana.0712-6sq.qe.rhcloud.com
openshift_logging_namespace=logging
openshift_logging_image_prefix=registry.ops.openshift.com/openshift3/
openshift_logging_image_version=v3.6.153
openshift_logging_es_pvc_dynamic=false
openshift_logging_es_pvc_size=50Gi
openshift_logging_fluentd_use_journal=true
openshift_logging_use_mux=false
openshift_logging_use_mux_client=false
Comment 7 Xia Zhao 2017-08-23 05:04:33 EDT
Checked with openshift-ansible-playbooks-3.6.173.0.7-2.git.0.340aa2c.el7.noarch

adding this parameter into inventory file of logging deployment:
openshift_logging_es_pvc_dynamic=false

after EFK stacks got running, checked that there is no pvc exist in -n logging:
# oc get pvc -n logging1
No resources found.

Set to verified.
Comment 9 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.