Bug 1463116 - The starting "Quota limit reached" text not indented well and the trailing "Check events" text broken into 2 lines in resource page
The starting "Quota limit reached" text not indented well and the trailing "C...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Robb Hamilton
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 03:35 EDT by Xingxing Xia
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 10:04:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quota-message-not-indented-well-in-resource-page (53.74 KB, image/png)
2017-06-20 03:35 EDT, Xingxing Xia
no flags Details
Check-events-text-not-in-one-line (76.20 KB, image/png)
2017-06-29 00:42 EDT, Xingxing Xia
no flags Details
good now (46.05 KB, image/png)
2017-07-06 07:46 EDT, Xingxing Xia
no flags Details

  None (edit)
Description Xingxing Xia 2017-06-20 03:35:51 EDT
Created attachment 1289466 [details]
quota-message-not-indented-well-in-resource-page

Description of problem:
Quota reached message is not indented well in resource page. But it is indented well in overview page.
The message in overview is indented like:
     Quota limit reached.
Scaling may be affected. Check events
While it is indented in resource page like (see attachment):
        Quota limit reached.
Scaling may be affected. Check
        events

Version-Release number of selected component (if applicable):
openshift v3.6.116

How reproducible:
Always

Steps to Reproduce:
1. (Below use OSO free to reproduce due to it has quota automatically).
Create project, create several pods to reach quota

2. Then create another scaled resource, like replicaset (other resource such as deployment, statefulset are similar)
$ oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/replicaSet/tc536601/replicaset.yaml

3. Check the quota reached message in overview page and the resource page

Actual results:
3. In overview page, the message is indented well
In resource page, the message is indented ugly

Expected results:
3. In resource page, the message is indented well too

Additional info:
Comment 1 Robb Hamilton 2017-06-20 13:56:45 EDT
PR to resolve bug: https://github.com/openshift/origin-web-console/pull/1747
Comment 3 Xingxing Xia 2017-06-29 00:42 EDT
Created attachment 1292779 [details]
Check-events-text-not-in-one-line

Checked in v3.6.126.1.
In resource page, now the starting text "Quota limit reached" is indented well as in overview.
But the trailing text "Check events" is still not in a single line.
Would it be better to be in a single line, as in overview? (Sorry my bad I didn't point explicitly the display of both the starting and trailing text in the message has position issues)
Comment 4 Robb Hamilton 2017-06-29 09:42:07 EDT
PR to address "Check events" link wrapping on deployments page:  https://github.com/openshift/origin-web-console/pull/1778
Comment 5 Xingxing Xia 2017-07-06 07:46 EDT
Created attachment 1294922 [details]
good now

Fixed in v3.6.134, now display is good, thanks!
Comment 6 Xingxing Xia 2017-07-06 07:47:19 EDT
QE is checking many Modified bugs to see if they're verifiable. Because fixed, moving to Verified. If have other concerns, pls tell me, thx

Note You need to log in before you can comment on or make changes to this bug.