Bug 1463121 - We should be more clear about the hostname setting for the IPA container
We should be more clear about the hostname setting for the IPA container
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Using-Containerized-Identity-Management-Services (Show other bugs)
7.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Aneta Šteflová Petrová
ipa-qe
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 03:52 EDT by Thorsten Scherf
Modified: 2018-03-27 04:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-27 04:44:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2017-06-20 03:52:11 EDT
Document URL: 

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7.4-beta/html/using_containerized_identity_management_services/deploying-an-identity-management-server-in-a-container#deploying-server-prerequisites-and-recommendations-deploying-an-identity-management-server-in-a-container

Section Number and Name: 
2.3. Installing an Identity Management Server in a Container: Basic Installation

Describe the issue: 

In the doc we say:

"""
Use the atomic install rhel7/ipa-server --hostname fully_qualified_domain_name command to start the installation. 
""" 

And also:

"""
To prevent the installation from failing, always use the --hostname option with atomic install to set the fully-qualified host name (FQDN) of the new Identity Management system. 
"""

We should be more clear here that the IPA container requires its own hostname which is also resolvable via DNS and/or /etc/hosts. The IPA container is network namespaced (SSSD container is not) and will therefore also get its own IP address.

If people just do something like "--hostname `hostname` during the container setup, the IPA container will use the same hostname which is also used on the Atomic host. When you now try to enroll a SSSD container into the new IPA domain, the enrollment will fail because the ipa-client-install script tried to connect to the Atomic host rather than the IPA container.



Suggestions for improvement: 

Additional information:
Comment 2 Aneta Šteflová Petrová 2018-02-26 05:40:15 EST
We have a prerequisite that says the IPA container requires its own host name:

~~~~
Use a different host name for the container than the host name of the Atomic Host system.

Installing a server or replica container does not enroll the Atomic Host system itself to the Identity Management domain. If you use the Atomic Host system’s host name for the server or replica, you will not be able to enroll the Atomic Host system later.
~~~~

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html-single/using_containerized_identity_management_services/#deploying-server-prerequisites-deploying-an-identity-management-server-in-a-container

But it looks like it's hard to find. It might be better to include it in the atomic install step(s), and possibly enhance it with the information from c#0.
Comment 6 Aneta Šteflová Petrová 2018-03-06 04:36:18 EST
This update affects these sections:

* 2.3. Installing an Identity Management Server in a Container: Basic Installation
* 2.4. Installing an Identity Management Server in a Container: External CA
* 2.5. Installing an Identity Management Server in a Container: Without a CA
* 3.3. Installing an Identity Management Replica in a Container: Basic Installation
* 3.4. Installing an Identity Management Replica in a Container: Without a CA

Step 1 in these installation procedures now says this about host names:

~~~~
1. Use the atomic install rhel7/ipa-server publish --hostname fully_qualified_domain_name ipa-server-install command to start the installation.

The container requires its own host name. Use a different host name for the container than the host name of the Atomic Host system. The container’s host name must be resolvable via DNS or the /etc/hosts file.

NOTE: Installing a server or replica container does not enroll the Atomic Host system itself to the Identity Management domain. If you use the Atomic Host system’s host name for the server or replica, you will be unable to enroll the Atomic Host system later.

IMPORTANT: Always use the --hostname option with atomic install when installing the server or replica container. Because --hostname is considered an Atomic option in this case, not an Identity Management installer option, use it before the ipa-server-install option. The installation ignores --hostname when used after ipa-server-install.
~~~~

Note You need to log in before you can comment on or make changes to this bug.