Bug 1463131 - Failed to container install ocp3.6 at task Determine the latest version of the OpenShift router deployment
Failed to container install ocp3.6 at task Determine the latest version of th...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Giuseppe Scrivano
liujia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 04:35 EDT by liujia
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description liujia 2017-06-20 04:35:06 EDT
Description of problem:
Failed to container install ocp3.6 at task [Determine the latest version of the OpenShift router deployment]. It should be "image" instead of "images" in router's deploy config.

failed: [openshift-151.x.x.x] (item={u'name': u'router', u'certificate': {}, u'replicas': u'1', u'serviceaccount': u'router', u'namespace': u'default', u'stats_port': 1936, u'edits': [{u'action': u'put', u'value': 1, u'key': u'spec.strategy.rollingParams.intervalSeconds'}, {u'action': u'put', u'value': 1, u'key': u'spec.strategy.rollingParams.updatePeriodSeconds'}, {u'action': u'put', u'value': 21600, u'key': u'spec.strategy.activeDeadlineSeconds'}], u'images': u'openshift3/ose-${component}:${version}', u'selector': u'region=infra', u'ports': [u'80:80', u'443:443']}) => {
    "cmd": "oc get deploymentconfig router --namespace default --config /etc/origin/master/admin.kubeconfig -o 'jsonpath={ .status.latestVersion }'", 
    "failed": true, 
    "item": {
        "certificate": {}, 
        "edits": [
            {
                "action": "put", 
                "key": "spec.strategy.rollingParams.intervalSeconds", 
                "value": 1
            }, 
            {
                "action": "put", 
                "key": "spec.strategy.rollingParams.updatePeriodSeconds", 
                "value": 1
            }, 
            {
                "action": "put", 
                "key": "spec.strategy.activeDeadlineSeconds", 
                "value": 21600
            }
        ], 
        "images": "openshift3/ose-${component}:${version}", 
        "name": "router", 
        "namespace": "default", 
        "ports": [
            "80:80", 
            "443:443"
        ], 
        "replicas": "1", 
        "selector": "region=infra", 
        "serviceaccount": "router", 
        "stats_port": 1936
    }, 
    "rc": 2
}

MSG:

[Errno 2] No such file or directory


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.6.116-1.git.0.e2840e8.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Trigger container install ocp3.6
2. 
3.

Actual results:
Install failed.

Expected results:
Install succeed.

Additional info:
Comment 1 liujia 2017-06-20 23:06:28 EDT
Blocked test based container on rhel env.
Comment 2 liujia 2017-06-21 03:35:10 EDT
Based on latest build(3.6.121), container install on rhel succeed. Remove testblocker keyword.
Comment 5 Giuseppe Scrivano 2017-06-27 03:58:16 EDT
PR here:

https://github.com/openshift/openshift-ansible/pull/4588
Comment 7 liujia 2017-06-28 05:44:35 EDT
Version:
atomic-openshift-utils-3.6.123.1003-1.git.0.002ceeb.el7.noarch

Steps:
1. Trigger container install ocp3.6 with user cloud-user

Install succeed. "/usr/local/bin/oc" is used instead of "oc" in task [Determine the latest version of the OpenShift router deployment].
Comment 9 errata-xmlrpc 2017-08-10 01:28:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.