Bug 1463138 - [free][free-int]Error message happens "system:serviceaccount:kube-system:horizontal-pod-autoscaler" cannot get deploymentconfigs/scale.extensions"
[free][free-int]Error message happens "system:serviceaccount:kube-system:hori...
Status: CLOSED DUPLICATE of bug 1458663
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Solly Ross
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 04:39 EDT by xipang
Modified: 2017-06-22 23:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-22 23:23:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xipang 2017-06-20 04:39:30 EDT
Description of problem:
The number of pods did not increase with autoscaler handling.

Version-Release number of selected component (if applicable):
openshift v3.6.116
kubernetes v1.6.1+5115d708d7

How reproducible:
Always

Steps to Reproduce:
1. Create a project and DC, expose svc
$ oc create -f https://raw.githubusercontent.com/mdshuai/testfile-openshift/master/hpa/dc-hello-hpa.yaml
$ oc expose rc hello-hpa-1 --port=8080
2.Go to DC page -> hello-hpa -> Add autoscaler
Set Min Pods: 2
Set Max Pods: 10
Set CPU Request Target: 1%
Click "Save"

Actual results:
$oc describe hpa $HPA_NAME
 ... ...
Events:
  FirstSeen	LastSeen	Count	From				SubObjectPath	Type		Reason		Message
  ---------	--------	-----	----				-------------	--------	------		-------
  44m		25s		88	horizontal-pod-autoscaler		Warning		FailedGetScale	User "system:serviceaccount:kube-system:horizontal-pod-autoscaler" cannot get deploymentconfigs/scale.extensions in project "<project-name>"


Expected results:
3. After some time, pod on number are increased, the max pod number is 10

Additional info:
the while loop did not increse pods
Whether due to the above event
Comment 1 Xingxing Xia 2017-06-20 05:57:41 EDT
FYI, to make clarity, the error "system:serviceaccount:kube-system:horizontal-pod-autoscaler" can be seen in `oc describe hpa $HPA_NAME` after the HPA is just created (no matter through CLI or web console). i.e. the error message is unrelated to increasing traffic to the app because the message is seen before user increases traffic to autoscale pod number
Comment 2 Jordan Liggitt 2017-06-21 00:36:14 EDT
Same root issue as https://bugzilla.redhat.com/show_bug.cgi?id=1458663#c1

The HPA controller is not being started with a client that knows how to look for origin resources, so it is looking for them in the extensions API group

https://github.com/openshift/origin/pull/14678 will resolve this
Comment 3 Seth Jennings 2017-06-22 23:23:11 EDT

*** This bug has been marked as a duplicate of bug 1458663 ***

Note You need to log in before you can comment on or make changes to this bug.