Bug 1463139 - [3.4]Failed to detect new openshift version due to miss cleaning yum repo during upgrade
[3.4]Failed to detect new openshift version due to miss cleaning yum repo dur...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.4.1
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.z
Assigned To: Russell Teague
liujia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 04:40 EDT by liujia
Modified: 2017-06-29 09:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the installer does not process a change to configured repos it will not refresh the cache. The fix will force a cache refresh in situations where repos were manually changed prior to running the upgrade.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 09:33:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1666 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-06-29 13:32:39 EDT

  None (edit)
Comment 1 Russell Teague 2017-06-20 13:37:58 EDT
Proposed: https://github.com/openshift/openshift-ansible/pull/4513
Comment 2 Russell Teague 2017-06-21 15:19:06 EDT
Merged: https://github.com/openshift/openshift-ansible/pull/4513
Comment 4 liujia 2017-06-27 02:15:24 EDT
Version:
atomic-openshift-utils-3.4.108-1.git.0.6b32ddc.el7.noarch

Steps:
1. Install ocp3.3
2. Prepare 3.4 repo with the same name as original 3.3 repo
3. Run upgrade playbook

Upgrade succeed.
Comment 6 errata-xmlrpc 2017-06-29 09:33:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1666

Note You need to log in before you can comment on or make changes to this bug.