Bug 1463162 - checkboxes don't be rendered correctly
checkboxes don't be rendered correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 05:29 EDT by Mik
Modified: 2017-06-20 17:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 17:49:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Capture from a test page in FF54 (5.20 KB, image/png)
2017-06-20 05:29 EDT, Mik
no flags Details

  None (edit)
Description Mik 2017-06-20 05:29:51 EDT
Created attachment 1289539 [details]
Capture from a test page in FF54

Description of problem:

checkboxes don't be rendered correctly

Version-Release number of selected component (if applicable):

Nom         : firefox
Architectur : x86_64
Époque      : 0
Version     : 54.0
Révision    : 2.fc25
Taille      : 152 M
Dépôt       : @System
Depuis le d : updates
Résumé      : Mozilla Firefox Web browser
URL         : https://www.mozilla.org/firefox/
Licence     : MPLv1.1 or GPLv2+ or LGPLv2+
Description : Mozilla Firefox is an open-source web browser, designed for
            : standards compliance, performance and portability.

Steps to Reproduce:

1. Display an html page with checkboxes


Actual results:

checkboxes are rendered with a 2-3 pixels point and are unselectable.

Expected results:

checkbox selectable and visible

Additional info:

see me capture. It's a test page with his code:

<html>
<body>
  <label for="filter_ref">
     <input name="filter_ref" id="filter_ref" value="1" type="checkbox">
     <span>On the left a checkbox</span>
  </label>
</body>
</html>
Comment 1 Martin Stransky 2017-06-20 05:34:40 EDT
Works for me as expected at gnome-shell/Adwaita. Which DE/Theme do you use?
Comment 2 Mik 2017-06-20 06:08:09 EDT
I use lxde/openbox with adwaita-dark theme but I tried Clearlook and checkbox doesn't rendered correctly too.
Comment 3 Martin Stransky 2017-06-20 06:24:41 EDT
Okay. can you please check Firefox nightly? You can use Fedora flatpak builds (https://firefox-flatpak.mojefedora.cz/) or download directly from mozilla.com (https://www.mozilla.org/cs/firefox/channel/desktop/).
Comment 4 Mik 2017-06-20 07:36:31 EDT
Ok I will try it this evening.
Comment 5 Mik 2017-06-20 17:49:03 EDT
I finally find the bug which come from a custom CSS rules in userContent.css. 

I made this rules because I got black font color on black background in some input field. 

But this rules also applied to the checkboxes. I tried to improve these rules.
So the problem is on my side.

Note You need to log in before you can comment on or make changes to this bug.