Bug 1463219 - Installing docker from Extras 7.3 emits weird message about Stopping containers and Cannot connect to the Docker daemon
Installing docker from Extras 7.3 emits weird message about Stopping containe...
Status: CLOSED DUPLICATE of bug 1456344
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Antonio Murdaca
atomic-bugs@redhat.com
: Extras
Depends On: 1538838
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 07:51 EDT by Jan Pazdziora
Modified: 2018-01-25 19:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 12:34:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2017-06-20 07:51:52 EDT
Description of problem:

When docker package is installed from Extras 7.3 via yum, message about

Cannot connect to the Docker daemon

is displayed.

Version-Release number of selected component (if applicable):

docker-1.12.6-28.git1398f24.el7.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. yum install -y docker

Actual results:

  Installing : python-IPy-0.75-6.el7.noarch                               12/17 
  Installing : libcgroup-0.41-11.el7.x86_64                               13/17 
  Installing : policycoreutils-python-2.5-11.el7_3.x86_64                 14/17 
  Installing : 2:container-selinux-2.12-2.gite7096ce.el7.noarch           15/17 
  Installing : libseccomp-2.3.1-2.el7.x86_64                              16/17 
Stopping containers...
Cannot connect to the Docker daemon. Is the docker daemon running on this host?
"docker stop" requires at least 1 argument(s).
See 'docker stop --help'.

Usage:  docker stop [OPTIONS] CONTAINER [CONTAINER...]

Stop one or more running containers
  Installing : 2:docker-1.12.6-28.git1398f24.el7.x86_64                   17/17 
  Verifying  : libseccomp-2.3.1-2.el7.x86_64                               1/17 
  Verifying  : libcgroup-0.41-11.el7.x86_64                                2/17 
  Verifying  : python-IPy-0.75-6.el7.noarch                                3/17 
  Verifying  : 1:oci-systemd-hook-0.1.7-2.git2788078.el7.x86_64            4/17 
  Verifying  : 2:docker-client-1.12.6-28.git1398f24.el7.x86_64             5/17 
  Verifying  : audit-libs-python-2.6.5-3.el7_3.1.x86_64                    6/17 

Expected results:

  Installing : python-IPy-0.75-6.el7.noarch                               12/17 
  Installing : libcgroup-0.41-11.el7.x86_64                               13/17 
  Installing : policycoreutils-python-2.5-11.el7_3.x86_64                 14/17 
  Installing : 2:container-selinux-2.12-2.gite7096ce.el7.noarch           15/17 
  Installing : libseccomp-2.3.1-2.el7.x86_64                              16/17 
  Installing : 2:docker-1.12.6-28.git1398f24.el7.x86_64                   17/17 
  Verifying  : libseccomp-2.3.1-2.el7.x86_64                               1/17 
  Verifying  : libcgroup-0.41-11.el7.x86_64                                2/17 
  Verifying  : python-IPy-0.75-6.el7.noarch                                3/17 
  Verifying  : 1:oci-systemd-hook-0.1.7-2.git2788078.el7.x86_64            4/17 
  Verifying  : 2:docker-client-1.12.6-28.git1398f24.el7.x86_64             5/17 
  Verifying  : audit-libs-python-2.6.5-3.el7_3.1.x86_64                    6/17 

Additional info:
Comment 4 Marko Myllynen 2017-06-21 03:14:32 EDT
This looks like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1456344 ?
Comment 5 Antonio Murdaca 2017-06-21 12:34:26 EDT
(In reply to Marko Myllynen from comment #4)
> This looks like a dupe of
> https://bugzilla.redhat.com/show_bug.cgi?id=1456344 ?

it is

*** This bug has been marked as a duplicate of bug 1456344 ***

Note You need to log in before you can comment on or make changes to this bug.