Bug 1463259 - [RFE] nmtui: allow widgets navigation with HJKL keys
[RFE] nmtui: allow widgets navigation with HJKL keys
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 08:56 EDT by Jan Pokorný
Modified: 2017-07-21 15:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 13:46:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2017-06-20 08:56:55 EDT
I don't know whether there are any limitations imposed with newt
library, but the desired state is that one can navigate using
HJKL keys (vim standard shared with plenty of other terminal
programs) along with cursor keys as usual.

Thanks for considering.
Comment 1 Lubomir Rintel 2017-07-21 13:46:26 EDT
Thanks for the report. However, it doesn't seem to be possible to tell newt to use different key bindings for navigation. The keycodes are hardcoded in the library.

I'm closing this bug report, since (despite we don't oppose the idea), we're not going to work on this and it falls outside of scope of NetworkManager. If you choose to reopen the bug, please reassign it to newt.

In that case I strongly suggest you attach a patch, otherwise it might be difficult to convince someone to actually implement this. It needs some serious thought -- the "hjkl" keys obviously collide with the other uses of the keys (search in list, enter text).

Lubo
Comment 2 Jan Pokorný 2017-07-21 15:21:43 EDT
Sad but understandable.
I immediately don't have the power to dive any deeper.

Note You need to log in before you can comment on or make changes to this bug.