Bug 1463318 - [GSS] [RFE] Improve gluster get-state output format [NEEDINFO]
[GSS] [RFE] Improve gluster get-state output format
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.2
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Samikshan Bairagya
Bala Konda Reddy M
: FutureFeature, ZStream
Depends On:
Blocks: 1408949 RHGS-usability-bug-GSS
  Show dependency treegraph
 
Reported: 2017-06-20 10:47 EDT by Cal Calhoun
Modified: 2017-10-09 00:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-09 00:37:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amukherj: needinfo? (ccalhoun)


Attachments (Terms of Use)

  None (edit)
Description Cal Calhoun 2017-06-20 10:47:11 EDT
Description	

What problem/issue/behavior are you having trouble with?  What do you expect to see?

Please improve output of 'gluster get-state' command.

- Use standard format. Current output looks like INI file, but with ":" instead of "="

- Add support for other output formats XML (--xml switch is not working) / YAML / JSON

- Add local brick device paths (for example /dev/mapper/something)

- Add local brick disk usage info

- Add overall gluster volume disk usage (if it will not cause additional overhead by contacting peers) 

- Add local brick heal entries info (if it will not cause additional overhead by contacting peers)
Comment 4 Cal Calhoun 2017-08-30 15:51:20 EDT
@Atin,

  From the customer:

  1) other format can be generated on user request by adding another command param (same as with --xml) -> it will not break old RHCS integration.

  2) ovirt based console 'is' or 'is going to be'  deprecated.  So default format can be changed later and 

  3) I'd like to see an option to be able to send output to stdout. get-state command behaves differently than other 'gluster *' commands 

  IMHO... to make things consistent: Get-state should defaults to stdout (like other gluster *) and should be able to create output file in different formats (INI,YAML,XML,JSON...) when appropriate parameter is used. We'd like to see native support for more output formats by default. I hope, this will happen at least in glusterd2.

-Cal

Note You need to log in before you can comment on or make changes to this bug.