Bug 1463373 - Mouse click bouncing with brand new mouse
Mouse click bouncing with brand new mouse
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-libinput (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 12:38 EDT by Ali Akcaagac
Modified: 2017-08-14 18:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 05:02:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mydevice description (657 bytes, application/x-bzip)
2017-06-22 04:10 EDT, Ali Akcaagac
no flags Details
mydevice events - part 1 (328.44 KB, application/x-bzip)
2017-06-22 04:12 EDT, Ali Akcaagac
no flags Details
mydevice events - part 2 (2.18 MB, application/x-bzip)
2017-06-22 04:18 EDT, Ali Akcaagac
no flags Details

  None (edit)
Description Ali Akcaagac 2017-06-20 12:38:50 EDT
I've been using a V220 Cordless Mouse (Logitech) for years under Linux. Some months ago I ran into heavy issues with single left mouse clicks to turn into double and tripple mouse clicks under Xorg.

This was quite annoying and I believed that this might be worn out left mouse buttons due to the age of the mouse.

A few weeks ago I bought a brand new M325 Cordless Mouse (Logitech) and had it run under Fedora 25. Worked so far until I switched to (what will become) Fedora 26.

With Fedora 26 I've been running into the Mouse click bouncing issue again and really didn't know what could've been the cause. A brand new mouse couldn't be worn out that fast I believed...

On Monday (19th June) I received the same Mouse again (M325 Logitech) as replacement and sent the old one back to the vendor.

Opened the blisterbox. Put the batteries in and was presented again with single mouse clicks turn into double and tripple mouse clicks.

Digging on the new I found this:

http://blog.guntram.de/?p=16
https://askubuntu.com/questions/321816/mouse-sometimes-doubleclicks-when-i-click-once

And the links inside the links that describe similar issues and missing "debounce" feature within the xev drivers. I am not really sure whether this only applies to one specific mouse type or not.

It would be necessary to have this sort of issue addressed and fixed... How ever the (or one) fix might look.
Comment 1 Ali Akcaagac 2017-06-20 14:50:52 EDT
Wrong component! Of course libinput is used in this context.

Just switched from 1.7.3 to what will become 1.8rc1 (recompiled from fedora srpm to see whether the issues still exist).

Bouncing is seriously an issue...
Comment 2 Peter Hutterer 2017-06-20 19:58:56 EDT
Please attach an evemu-record of one (or ideally more) of these clicks, thanks.
Comment 3 Ali Akcaagac 2017-06-22 04:10 EDT
Created attachment 1290552 [details]
mydevice description
Comment 4 Ali Akcaagac 2017-06-22 04:12 EDT
Created attachment 1290553 [details]
mydevice events - part 1
Comment 5 Ali Akcaagac 2017-06-22 04:18 EDT
Created attachment 1290555 [details]
mydevice events - part 2

Please find attached the requested files.

- description
- events 1 - from yesterday morning
- events 2 - from yesterday midday till night

I would like to add (in case it may matter) that the issues are bigger within gtk2 applications (e.g. like claws mail). But this could be related to signals attached to some widgets within the program that captures mouse presses.

As said, it's a brand new mouse (replacement to the sent back one). Opened from the blister box and batteries enabled. So it's quite unlikely that the buttons have been worn out right after opening the box... And it's the 3rd mouse in a row now... One old V220 (which I understood was old), a new M325 that worked well with Fedora 25 but started with issues under Fedora 26 (only a few weeks in use) and now the replacement M325 that arrived here a few days ago...
Comment 6 Peter Hutterer 2017-06-22 23:44:57 EDT
sorry, I need something more specific here. These recordings have thousands of events and it's hard for me to tell which ones are the real ones and which ones are the bouncy ones.

Try to reproduce this bounciness in a short recording please, just ctrl+c evemu after a few seconds if it doesn't reproduce. Or use the --autoresume flag for evemu-record.
Comment 7 Ali Akcaagac 2017-08-09 05:02:58 EDT
Coming back to the issue... To make it short... I've yet bought another mouse (not from Logitech) and the issues are - of course - gone...

After some investigations into the issue (reading other resources) it came to my attention that Logitech has lately build in cheap Omron micro switches in their mouse. These micro switches seem to have issues (not lasting long enough... Not even over their promised guarantee time). It was easier to bypass the issue completely by changing the brand, rather than investigating further into mouse click issues...

With other words... I will close this report as not a bug... because it looks like it really isn't one...
Comment 8 Peter Hutterer 2017-08-14 18:47:34 EDT
just as a fyi, the next version of libinput has button debouncing built-in, so the old mouse should work again. Not sure yet when that one will be released though.

Note You need to log in before you can comment on or make changes to this bug.