Bug 1463382 - take-over-existing-cluster.yml doesn't work at all in ceph-ansible-2.2.11-1
take-over-existing-cluster.yml doesn't work at all in ceph-ansible-2.2.11-1
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 3.0
Assigned To: David Galloway
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 13:33 EDT by David Galloway
Modified: 2017-08-02 07:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 07:42:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ceph/ceph-ansible/pull/1613 None None None 2017-07-06 07:10 EDT

  None (edit)
Description David Galloway 2017-06-20 13:33:23 EDT
Description of problem:
take-over-existing-cluster.yml fails due to a bug introduced in https://github.com/ceph/ceph-ansible/commit/4639d89231dc35c743ded29ed0f962f36a4b0574.

This task now basically stats the string of the cluster name and so the next task fails due to missing dict values: https://github.com/ceph/ceph-ansible/blob/4639d89231dc35c743ded29ed0f962f36a4b0574/infrastructure-playbooks/take-over-existing-cluster.yml#L35-L38

Version-Release number of selected component (if applicable):
ceph-ansible-2.2.11-1

How reproducible:
Every time

Steps to Reproduce:
1. Install ceph-ansible-2.2.11-1.el7scon.noarch
2. Follow downstream docs to take over an existing cluster

Actual results:
Playbook fails

Expected results:
Successful new ceph.conf creation

Additional info:
We also *really* should be making backups of the original ceph.conf IMO.  I'm working on this in a branch on upstream ceph-ansible.
Comment 2 David Galloway 2017-06-20 14:00:10 EDT
https://github.com/ceph/ceph-ansible/pull/1613 should fix this.
Comment 3 Gregory Meno 2017-06-26 17:05:09 EDT
Thomas would you please tell us how you are tracking work to be released in the next 2.x async release? This is a candidate for that.
Comment 6 Federico Lucifredi 2017-08-02 07:42:07 EDT
Running take-over-existing-cluster is valid in 2.x as we changed from ceph-deploy (in 1.3) to ceph-ansible in 2.0 and had to provide a way for customer to make sure the existing cluster is brought under ceph-ansible control to handle management tasks like add/remove osds.

In 3.0, the assumption is that either cluster is installed newly or upgraded from 2.x. In both cases, take over use case is not applicable in 3.0.

Note You need to log in before you can comment on or make changes to this bug.