Bug 146339 - Unable to run firefox after installing FC3 problem with JS_dtostr
Unable to run firefox after installing FC3 problem with JS_dtostr
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2005-01-27 02:17 EST by Richard Hubbell
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-24 17:02:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard Hubbell 2005-01-27 02:17:45 EST
Description of problem:
firefox seg faults and drops core on startup

Version-Release number of selected component (if applicable):
firefox 1.0 and fedora core 3 with no updates

How reproducible:
1. install an abbreviated fc3
   o  xfce
   o  xdm
   o  no kde, no gnome, no graphics, just enough to
      have a working system

Actual results:

trace from core file reveals we get to nsProfileLock's
Looks like JS_dtostr in libmozjs.so is the culprit
also js_NumberToString  (looks the same)

Expected results:
firefox starts

Additional info:
I did a lot of searching and subscribed to fedora-devel.
There seems to be a problem with gcc  search google for prdtoa.c
and you'll see what I mean.

I even tried to build firefox (AVIARY branch) but ran into the
same problem but it cropped up in shlibsign.

I installed FC3 twice on a fresh disk same result both times
Comment 1 Sitsofe Wheeler 2005-01-27 18:36:51 EST
What does "rpm -q firefox" say?
Comment 2 Richard Hubbell 2005-01-27 23:00:21 EST
I should have said that comes with FC3, I thought it was 1 but it's

Also included the anaconda kickstart file:
# Kickstart file automatically generated by anaconda.

lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
xconfig --card "ATI Rage 128" --videoram 32768 --hsync 30-96 --vsync 50-140
--resolution 800x600 --depth 16
network --device eth0 --bootproto dhcp
rootpw --iscrypted 
firewall --enabled
selinux --disabled
authconfig --enableshadow --enablemd5
timezone America/Tijuana
bootloader --location=mbr
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux
#part / --fstype "ext3" --onpart hda1
#part swap --noformat --onpart hda2

@ editors
@ xemacs
@ system-tools
@ dialup
@ authoring-and-publishing
@ xfce-desktop
@ base-x
@ printing
@ development-tools

Comment 3 Richard Hubbell 2005-02-02 11:25:09 EST
To 'ye who reads this here message.....shall I be givin' up all hope on this? 
No doubt there are more important bugs.  I have abandoned all hope.  Installing
new firefox from mozilla.org gives me same problem.
Comment 4 Christopher Aillon 2005-02-02 11:41:40 EST
I think I've heard reports that the i386 version works.  Have you tried that? 
Unfortunately, I won't be able to get to look at this for a while, but it is on
the list of bugs I have flagged to fix for FC4.
Comment 5 Richard Hubbell 2005-02-02 12:03:31 EST
Dunno where to find i386 version??  I only find this

Comment 6 Barry K. Nathan 2005-02-06 00:25:58 EST
Between comment #2 and the fact that this bug is filed against athlon not
x86_64, I think Richard Hubbell already tried the i386 version and still hit
this problem. (I haven't seen this problem however.)
Comment 7 Richard Hubbell 2005-02-09 11:23:19 EST
To Barry K. Nathan, how did you try to repro?  Or are you just saying
"I don't have this problem, haven't ever seen this problem from anyone" ?
Comment 8 Barry K. Nathan 2005-02-09 18:24:20 EST
I'm saying whenver I've installed FC3, firefox has Just Worked(tm). I've never
seen this crash.

I don't think I've tried installing X and Firefox on a minimal install and
testing that setup, however. (It's possible that I did that once and that it
also worked for me, but I don't remember for sure, so I need to try again at
some point. "some point" definitely won't be today or tomorrow, though.)
Comment 9 Richard Hubbell 2005-02-16 19:20:40 EST
I suppose I've had stranger hardware problems, but this ranks right up there. 
Turns out my cpu was bad.  Don't understand anything more about it. I could do
most everything on the computer.  Exceptions were running any browser.  firefox,
mozilla, konqueor, opera.  All a no go. The GTK color picker would crash.  I had
problems with gpg, but only in some versions.  I finally realized it was a cpu
problem after running seti.  It behaved very strangely and I got OVERFLOW errors.
I could compile linux kernels with no apparent problems either.  All is a go
after replacing the athlon with a duron.  I can't figure out how to retire this
so I'll leave that up to you.
Comment 10 Barry K. Nathan 2005-02-16 22:06:30 EST
It should be closed as "NOTABUG". (I'm not the bug reporter, nor am I a Red Hat
employee, so I can't do that myself.)
Comment 11 Matthew Miller 2005-02-24 17:02:55 EST
closing NOTABUG as per comment #10.

Note You need to log in before you can comment on or make changes to this bug.