Bug 1463391 - Routes are failing to update on starter-us-east-1
Routes are failing to update on starter-us-east-1
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ben Bennett
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-20 14:32 EDT by Stefanie Forrester
Modified: 2017-06-21 13:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 10:51:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefanie Forrester 2017-06-20 14:32:50 EDT
Description of problem:

It was reported earlier today that routes were taking at least an hour to become functional on starter-us-east-1. During my testing, 20 out of 20 test apps still are reporting 503s when I try to curl the route, even 30+ minutes after the app started Running. It's unknown how long routes will take to start working (if ever), but there is a very long delay between when a pod enters Running and state when the route will return a 200.

Version-Release number of selected component (if applicable):
v3.5.5.19

How reproducible:

Every time, on this cluster https://console.starter-us-east-1.openshift.com

Steps to Reproduce:
1. Create a project.
2. Wait 5 minutes before creating an app, because of this missing token bug https://bugzilla.redhat.com/show_bug.cgi?id=1462542
3. Create an app in the new project.

Actual results:

The route does not return a 200. It returns 503 for a very long time.

Expected results:

The route should return 200 as soon as the backing pod is ready and Running.

Additional info:
Comment 5 Ben Bennett 2017-06-21 10:30:20 EDT
If you are using https://github.com/openshift/origin/blob/master/examples/quickstarts/cakephp-mysql-persistent.json then you need to use http not https to hit the routes.
Comment 6 Eric Paris 2017-06-21 13:25:18 EDT
Or create/edit the route with edge termination

oc patch route -n ${namespace} ${route} -p '{"spec":{"tls": {"termination": "edge", "insecureEdgeTerminationPolicy": "Allow"}}}'

Note You need to log in before you can comment on or make changes to this bug.