Bug 14634 - total memory not correctly detected with 2.2.16-3 on Tyan motherboard
Summary: total memory not correctly detected with 2.2.16-3 on Tyan motherboard
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-25 19:56 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 16:42:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-07-25 19:56:05 UTC
Hi,

I have a Tyan S1834D Dual motherboard (Apollo Via 133 controller) with 1
Gigabyte of RAM
and two pentium-III 733 MHz. I was running kernel 2.2.14-5.0smp and the
total amount
of physical ram installed was correctly detected in /proc/meminfo , however
I just installed
2.2.16-3smp and it turns out that now the physical memory detected is 100
Mb less than what 
it should be. Below is the output of "cat /proc/meminfo" where you can see
that the line
"MemTotal" is incorrect.  I added ' append="mem=1023M" ' to /etc/lilo.conf
in order
to try to temporarily fix the problem, did "lilo -v" and rebooted but that
did not change anything (!!). I also tried booting the non-SMP kernel but
still noticed the same problem. Any idea what the problem could be? Any
known fix?

## with old 2.2.14-5.0smp kernel (standard RH 6.2 CD)

komatits-n001(101):  cat /proc/meminfo 
        total:    used:    free:  shared: buffers:  cached:
Mem:  1061060608 51617792 1009442816 49016832 18149376  7925760
Swap: 542826496        0 542826496
MemTotal:   1036192 kB
MemFree:     985784 kB
MemShared:    47868 kB
Buffers:      17724 kB
Cached:        7740 kB
BigTotal:     65472 kB
BigFree:      58988 kB
SwapTotal:   530104 kB
SwapFree:    530104 kB


## with new 2.2.16-3smp kernel
## same problem even if I add ' append="mem=1023M" ' to /etc/lilo.conf +
lilo -v + reboot

komatits-n001(102): cat /proc/meminfo 
        total:    used:    free:  shared: buffers:  cached:
Mem:  928153600 38350848 889802752 11272192  3284992 21065728
Swap: 542826496        0 542826496
MemTotal:    906400 kB
MemFree:     868948 kB
MemShared:    11008 kB
Buffers:       3208 kB
Cached:       20572 kB
BigTotal:         0 kB
BigFree:          0 kB
SwapTotal:   530104 kB
SwapFree:    530104 kB

Comment 1 Need Real Name 2000-07-26 08:15:50 UTC
I also noticed that this happens only when I put 1 Gigabyte of RAM. If I put 256
Mb or
768 Mb everything is fine with kernel 2.2.16-3. (the Gigabyte of RAM is
correctly
detected by the BIOS during boot POST)

dimitri


Comment 2 Alan Cox 2000-08-22 16:54:40 UTC
The kernels built for 1Gig max, are actually about 920Mb (some virtual space is
needed for
other stuff like PCI maps). Im wondering why the bigmem kernel/support wasnt
used but
that would be an installer issue I think

Perhaops someone is checking 1Gig not 900Mb there 



Comment 3 Michael Fulbright 2000-11-09 22:40:38 UTC
Passed to QA to attempt to reproduce.

Comment 4 Brock Organ 2000-11-13 16:47:43 UTC
we are unable to see this problem in test w/similar (but not exact!) hardware
... do you have this problem with any other kernels besides 2.2.16-3smp?

Comment 5 Need Real Name 2000-11-18 03:40:30 UTC
No. I switched to kernel 2.4 beta version test8 two months ago
and since then everything works fine. the full Gb of RAM is correcly
seen by the system. I had to compile the kernel with the "RAM up to 4Gb"
on of course

dimitri

Comment 6 Michael Fulbright 2000-11-21 15:25:43 UTC
Thank you for this additional information.

Comment 7 Michael Fulbright 2001-01-11 16:42:08 UTC
Since this is dependent on a newer kernel to function correctly we cannot fix
this in the installer.


Note You need to log in before you can comment on or make changes to this bug.