Bug 146340 - Nvidia 6629 driver is broken on 1107-1110 inclusive
Nvidia 6629 driver is broken on 1107-1110 inclusive
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 03:01 EST by Ivan Gyurdiev
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-01-27 03:01:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
The nvidia closed source graphics driver will not install since the 
1107 kernel. The last kernel on which it installed properly 
was 1105.

Here's a log of the problem. 
Let me know if you think I should bother Nvidia support instead.
This is the 6629 driver patched with:

http://www.minion.de/files/1.0-6629/NVIDIA_kernel-1.0-6629-1161283.diff


In file included from include/linux/list.h:7,                  from
include/linux/wait.h:23,
                 from include/asm/semaphore.h:41,                 
from include/linux/sched.h:19,
                 from include/linux/module.h:10,                  from
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/nv-linux.h:52,
                 from
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:24:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in
arithmetic
In file included from include/linux/dmapool.h:14,
                 from include/linux/pci.h:863,                  from
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/nv-linux.h:75,
                 from
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:24:
include/asm/io.h: In function `check_signature':
include/asm/io.h:242: warning: wrong type argument to increment
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:
At top level:
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:48:
error: syntax error before '*' token
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:48:
warning: type defaults to `int' in declaration of `drm_agp_p'
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:48:
warning: data definition has no type or storage class
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:
In function `KernInitAGP':
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:76:
warning: assignment discards qualifiers from pointer target type
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:85:
error: request for member `acquire' in something not a structure or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:88:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:581)
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:113:
error: request for member `copy_info' in something not a structure or
union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:173:
error: request for member `enable' in something not a structure or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:185:
error: request for member `release' in something not a structure or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:186:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:581)
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agpNVIDIA:
left KBUILD.
nvidia.ko failed to build!
/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:216: error:
request for member `release' in something not a structure or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:218:
warning: `inter_module_put' is deprecated (declared at
include/linux/module.h:581)
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:
In function `KernAllocAGPPages':
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:265:
error: request for member `allocate_memory' in something not a
structure or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:273:
error: request for member `bind_memory' in something not a structure
or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:290:
error: request for member `unbind_memory' in something not a structure
or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:305:
error: request for member `free_memory' in something not a structure
or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:
In function `KernMapAGPPages':
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:345:
error: request for member `unbind_memory' in something not a structure
or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:
In function `KernFreeAGPPages':
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:444:
error: request for member `unbind_memory' in something not a structure
or union
/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.c:445:
error: request for member `free_memory' in something not a structure
or union
make[4]: ***
[/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv/os-agp.o]
Error 1
make[3]: ***
[_module_/home/phantom/src/NVIDIA-Linux-x87-1.0-6629-pkg1/usr/src/nv]
Error 2
make[2]: *** [modules] Error 2
make[1]: *** [module] Error 1
make: *** [install] Error 2


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.1110_FC4

How reproducible:
Always

Steps to Reproduce:
1. See summary
    

Additional info:
Comment 1 Dave Jones 2005-01-27 09:04:40 EST

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 Ivan Gyurdiev 2005-01-27 11:48:19 EST
If that's your way to tell me to go away, can you 
at least hint as to why this is happening?
Comment 3 Dave Jones 2005-01-27 11:49:59 EST
its an nvidia problem, tell them, not us.
Comment 4 Ivan Gyurdiev 2005-01-27 12:07:04 EST
See the thing is... the nvidia driver stayed the same,
while the kernel changed. That implies the kernel people
are to ask what happened, especially since this looks
like a header issue of some kind, not a runtime bug.

It's allright though I guess I won't need your help.

I think,

Date	Wed, 19 Jan 2005 18:38:32 -0800
From	Chris Wedgwood <>
Subject	[PATCH RFC] agp_backend: remove drm_agp_t & inter_module_<foo> V1 

is to blame.

It's still frustrating when people refuse to even look at
Nvidia bugs. You lose beta testers in this way.
Comment 5 Dave Jones 2005-01-27 12:20:44 EST
if you use out-of-kernel-tree modules, you have to accept all the pain
that comes along with them, which includes breakage when you run
latest kernels while nvidia havent updated their wrappers.

out-of-tree modules never have, and never will hold up progress.

DRI/AGP got a considerable amount of fixing in 2.6.11rc, breakage of
binary modules is a minor price to pay in the long run for
maintainable code.

I'd suggest you bring it up on an nvidia forum somewhere, as no doubt
others have run into this problem, and possibly fixed it up.

Either way-- it's not a kernel bug.
Comment 6 Red Hat Bugzilla 2006-02-21 14:08:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.