Bug 1463436 - Kibana: ACL error when attempting "Export All" saved searches/dashboards/visualizations
Kibana: ACL error when attempting "Export All" saved searches/dashboards/visu...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.6.z
Assigned To: Jeff Cantrill
Anping Li
:
Depends On:
Blocks: 1463437 1463438
  Show dependency treegraph
 
Reported: 2017-06-20 18:39 EDT by Rich Megginson
Modified: 2017-10-25 09:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Non-operations users were not given the proper access to scroll data Consequence: Users will see a 403 action denied in Kibana Fix: Provide 'cluster' level permissions for the failed action for ordinary users Result: Users are able to export ui objects
Story Points: ---
Clone Of:
: 1463437 (view as bug list)
Environment:
Last Closed: 2017-10-25 09:02:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github fabric8io/openshift-elasticsearch-plugin/pull/98 None None None 2017-08-29 16:09 EDT
Github openshift/origin-aggregated-logging/pull/571 None None None 2017-09-01 11:59 EDT
Github openshift/origin-aggregated-logging/pull/637 None None None 2017-09-05 14:09 EDT
Red Hat Product Errata RHBA-2017:3049 normal SHIPPED_LIVE OpenShift Container Platform 3.6, 3.5, and 3.4 bug fix and enhancement update 2017-10-25 11:57:15 EDT

  None (edit)
Description Rich Megginson 2017-06-20 18:39:05 EDT
Description of problem:
Cannot "Export All" saved searches/dashboards/visualizations from the Kibana Settings -> Objects tab.  No immediate feedback, just nothing happens.  ACL error is revealed by looking at the web console/debugger in the browser.

Version-Release number of selected component (if applicable):
3.6 and earlier

How reproducible:
Every time

Steps to Reproduce:
1. Launch Kibana
2. Go to the Settings tab
3. Go to the Objects tab
4. Press the "Export All" button

Actual results:
Nothing happens.

Expected results:
Export all of the saved objects in a single JSON file.

Additional info:
Comment 1 Jeff Cantrill 2017-08-25 17:01:46 EDT
Issue is for non-ops users and generates a 403 trying to POST:

https://kibana.192.168.122.61.nip.io/elasticsearch/_search/scroll
Comment 2 Jeff Cantrill 2017-08-25 17:09:31 EDT
What does this mean?  When i list the indices I do not see an elasticsearch index to which I need to give search action permissions.
Comment 3 Peter Portante 2017-08-25 21:01:58 EDT
Not sure, I think we need to debug to find out.
Comment 4 Jeff Cantrill 2017-08-29 13:54:47 EDT
I believe this results from an error with searchguard that I filed here: https://github.com/floragunncom/search-guard/issues/377 We probably will need to patch if we can not convince them to fix
Comment 5 openshift-github-bot 2017-09-01 23:31:08 EDT
Commit pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/476a022d964c1ca6f6365105825ff2127cdb32e0
bug 1463436. Allow defining cluster perms to allow export of ui objects
bump es plugin to 2.4.4.13 for user based roles
Comment 7 Anping Li 2017-09-14 05:38:24 EDT
Using version v3.6.173.0.33, the save file can be exported, so move bug to verified.
Comment 9 errata-xmlrpc 2017-10-25 09:02:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049

Note You need to log in before you can comment on or make changes to this bug.