Bug 1463498 - sti build is still pushing image to registry by IP but not DNS in master HA env.
sti build is still pushing image to registry by IP but not DNS in master HA env.
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 02:55 EDT by Johnny Liu
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2017-06-21 02:55:36 EDT
Description of problem:
See below details.

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.121-1.git.0.ed0b72c.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Trigger a fresh installation with multiple masters.
2. After installation, trigger a sti build.
3.

Actual results:
# oc logs -f nodejs-mongodb-example-1-build -n install-test
<--snip-->
Pushing image 172.31.224.169:5000/install-test/nodejs-mongodb-example:latest ...
Pushed 0/5 layers, 0% complete
Pushed 1/5 layers, 22% complete
Pushed 2/5 layers, 48% complete
Pushed 3/5 layers, 74% complete
Pushed 4/5 layers, 100% complete
Pushed 5/5 layers, 100% complete
Push successful

image is still pushed to registry by IP, but not DNS.

Expected results:
image should be pushed to registry by DNS.

Additional info:
In a sigle-master env, image is pushed to registry by DNS.
The root cause is "OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000" is setting in /etc/sysconfig/atomic-openshift-master, but missing in /etc/sysconfig/atomic-openshift-master-{api,controllers}.
Comment 2 Johnny Liu 2017-06-27 06:58:26 EDT
Only could find openshift-ansible-3.6.126-1.git.0.58d33f0.el7.noarch from the latest puddle (AtomicOpenShift/3.6/2017-06-27.1) does not have the fix.
Comment 3 Scott Dodson 2017-06-27 17:34:05 EDT
in openshift-ansible-3.6.123.1002-1.git.0.506cfa7.el7
Comment 4 Johnny Liu 2017-06-27 20:31:23 EDT
Verified this bug with openshift-ansible-3.6.123.1002-1.git.0.506cfa7.el7.noarch, and PASS.

[root@jialiu-master-etcd-zone2-1 ~]# cat /etc/sysconfig/atomic-openshift-master-api 
OPTIONS=--loglevel=5 --listen=https://0.0.0.0:443 --master=https://jialiu-master-etcd-zone2-1
CONFIG_FILE=/etc/origin/master/master-config.yaml
OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000
IMAGE_VERSION=v3.6.126


# Proxy configuration
# See https://docs.openshift.com/enterprise/latest/install_config/install/advanced_install.html#configuring-global-proxy
[root@jialiu-master-etcd-zone2-1 ~]# cat /etc/sysconfig/atomic-openshift-master-controllers 
OPTIONS=--loglevel=5 --listen=https://0.0.0.0:8444
CONFIG_FILE=/etc/origin/master/master-config.yaml
OPENSHIFT_DEFAULT_REGISTRY=docker-registry.default.svc:5000
IMAGE_VERSION=v3.6.126


# Proxy configuration
# See https://docs.openshift.com/enterprise/latest/install_config/install/advanced_install.html#configuring-global-proxy


# oc logs -f cakephp-mysql-example-1-build -n install-test
<--snip-->
OK (1 test, 1 assertion)
Pushing image docker-registry.default.svc:5000/install-test/cakephp-mysql-example:latest ...
Pushed 0/5 layers, 2% complete
Pushed 1/5 layers, 36% complete
Pushed 2/5 layers, 57% complete
Pushed 3/5 layers, 84% complete
Pushed 4/5 layers, 100% complete
Pushed 5/5 layers, 100% complete
Push successful
Comment 6 errata-xmlrpc 2017-08-10 01:28:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.