This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1463517 - Brick Multiplexing:dmesg shows request_sock_TCP: Possible SYN flooding on port 49152 and memory related backtraces
Brick Multiplexing:dmesg shows request_sock_TCP: Possible SYN flooding on por...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
3.11
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Mohammed Rafi KC
brick-multiplexing
:
Depends On: 1453145 1456405
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 03:41 EDT by Mohammed Rafi KC
Modified: 2017-08-12 09:07 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.11.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1456405
Environment:
Last Closed: 2017-08-12 09:07:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-06-21 03:43:16 EDT
REVIEW: https://review.gluster.org/17588 (socket/reconfigure: reconfigure should be done on new dict) posted (#1) for review on release-3.11 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Worker Ant 2017-06-21 03:43:22 EDT
REVIEW: https://review.gluster.org/17589 (protocol/server: make listen backlog value as configurable) posted (#1) for review on release-3.11 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Worker Ant 2017-07-03 08:49:36 EDT
COMMIT: https://review.gluster.org/17588 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 4328d6412d30ce538ec87e1f124ebe3b2a0e131e
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon May 29 16:19:40 2017 +0530

    socket/reconfigure: reconfigure should be done on new dict
    
    In socket reconfigure, reconfigurations are doing with old
    dict values. It should be with new reconfigured dict values
    
    Backport of>
    >Change-Id: Iac5ad4382fe630806af14c99bb7950a288756a87
    >BUG: 1456405
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: https://review.gluster.org/17412
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: Iac5ad4382fe630806af14c99bb7950a288756a87
    BUG: 1463517
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: https://review.gluster.org/17588
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Zhou Zhengping <johnzzpcrystal@gmail.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 4 Shyamsundar 2017-08-12 09:07:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.2, please open a new bug report.

glusterfs-3.11.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-July/031908.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.