Bug 1463553 - Templates in openshift-ansible are not up-to-date to reflect new change for origin pull request #14486
Templates in openshift-ansible are not up-to-date to reflect new change for o...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Russell Teague
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 04:40 EDT by Wenjing Zheng
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Templates updated to origin latest.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2017-06-21 04:40:11 EDT
Description of problem:
Updated templates in below pull request are not synced to openshift-ansible which cause no new template after environment is launched: https://github.com/openshift/origin/pull/14486

These templates are updated in ose repo:
https://github.com/openshift/ose/tree/master/examples/db-templates

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.121-1.git.0.ed0b72c.el7.noarch.rpm

https://github.com/openshift/openshift-ansible/tree/openshift-ansible-3.6.121-1/roles/openshift_examples/files/examples/v3.6

How reproducible:
always

Steps to Reproduce:
1. Check the templates installed in ocp
2.
3.

Actual results:
No change for below pull request:
https://github.com/openshift/origin/pull/14486

Expected results:
The templates should contain changes in origin pull request #14486.

Additional info:
Comment 1 Scott Dodson 2017-06-21 10:17:49 EDT
cd roles/openshift_examples
./examples-sync.sh

review diff, commit, push up a pr
Comment 2 Russell Teague 2017-06-21 10:26:57 EDT
Proposed: https://github.com/openshift/openshift-ansible/pull/4528
Comment 3 Russell Teague 2017-06-22 13:11:44 EDT
Merged: https://github.com/openshift/openshift-ansible/pull/4528
Comment 5 Johnny Liu 2017-06-26 02:23:35 EDT
Verified this bug with openshift-ansible-3.6.124-1.git.0.507a059.el7.noarch, and PASS.
# oc edit template mariadb-ephemeral -n openshift -o json
<--snip-->
    "objects": [
        {
            "apiVersion": "v1",
            "kind": "Secret",
            "metadata": {
                "annotations": {
                    "template.openshift.io/expose-password": "{.data['database-password']}",
                    "template.openshift.io/expose-root-password": "{.data['database-root-password']}",
                    "template.openshift.io/expose-username": "{.data['database-user']}"
                },
                "name": "${DATABASE_SERVICE_NAME}"
            },
            "stringData": {
                "database-password": "${MYSQL_PASSWORD}",
                "database-root-password": "${MYSQL_ROOT_PASSWORD}",
                "database-user": "${MYSQL_USER}"
            }
        },
<--snip-->

# oc get template -n openshift|grep httpd-example
httpd-example                                   An example Httpd application that serves static content. For more information...   9 (3 blank)       5
# oc get is -n openshift|grep http
httpd                                 docker-registry.default.svc:5000/openshift/httpd                               latest,2.4                         3 hours ago
Comment 7 errata-xmlrpc 2017-08-10 01:28:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.