Bug 1463572 - Not able to delete pending sign certificates [NEEDINFO]
Not able to delete pending sign certificates
Status: CLOSED DUPLICATE of bug 1373785
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Puppet (Show other bugs)
6.2.9
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 05:05 EDT by maneesh verma
Modified: 2017-10-12 03:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-12 03:13:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhulan: needinfo? (mverma)


Attachments (Terms of Use)

  None (edit)
Description maneesh verma 2017-06-21 05:05:43 EDT
Description of problem:

Not able to delete pending request certificates of client registered using Capsule server.


How reproducible:

Every time a client registers to Capsule server and run puppet agent -tv.

Steps to Reproduce:
1.Reister a client machine using capsule katello-ca-consumer rpm.
2.Run puppet agent -tv on the client machine by changing the server URL to Capsule server in /etc/puppet/puppet.conf
3.Click on Satellite Web UI>Infrastructures>Capsules>Our capsule server>Puppet CA>Certificates.

Click on Delete button for the pending certificates.

Actual results:
Certificate stays back even after clicking on the delete button, it says deleted but doesn't go away.

Expected results:
It should delete the certificate permanently.

Additional info:
Comment 1 Marek Hulan 2017-09-18 07:07:11 EDT
Maneesh, please provide production.log and proxy.log from a capsule that the puppet agent was registered to (for both turn debug log level first). See https://access.redhat.com/solutions/1155573 for more details
Comment 2 Ondřej Pražák 2017-10-12 03:13:40 EDT
Thank you for reporting this bug, I believe we already track this as #1373785, therefore I will close as a duplicate. Feel free to reopen if that is not the case.

*** This bug has been marked as a duplicate of bug 1373785 ***

Note You need to log in before you can comment on or make changes to this bug.