Bug 146361 - <th> headers won't show up on hardware profile page
<th> headers won't show up on hardware profile page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Máirín Duffy
Vlady Zlatkin
:
Depends On: 147145
Blocks: 178198 203362
  Show dependency treegraph
 
Reported: 2005-01-27 10:42 EST by Matthew Davis
Modified: 2008-05-09 13:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn406
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 14:34:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
busted css example (46.17 KB, image/png)
2006-02-13 17:35 EST, Máirín Duffy
no flags Details
the way it should look (34.98 KB, image/png)
2006-02-13 17:35 EST, Máirín Duffy
no flags Details

  None (edit)
Description Matthew Davis 2005-01-27 10:42:26 EST
Description of problem:

The header text is white when it should be shown at all times.

Version-Release number of selected component (if applicable):

Hosted/3.6.2

How reproducible:

Everytime

Steps to Reproduce:
(Using both Firefox and Mozilla)
1. Login to RHN
2. Select profile
3. Select hardware tab
4. Look at Networking, storage, video, etc headers..
5. Highlight the entire table and you'll magically see the text in the headers
specified by the <th> tag.

Actual results:

<th> tags turn from hidden to shown when highlighted.

Expected results:

<th> text should always be displayed, since someone took the time to write them.
Comment 2 Todd Warner 2005-02-04 10:42:17 EST
Customer Facing now "NO"
Docs status now tracked by bug 147145
Comment 4 Max Spevack 2005-08-29 14:49:29 EDT
mass assign rhn410 QA contact
Comment 7 Máirín Duffy 2005-11-30 11:31:47 EST
We fixed the SSM th headers cliff mentioned in comment 1 in rhn400 (bug 158337)

The reason this is happening is because rhn-360.css has a style that applies to
all th headers that turns them white, presumably for the listviews where the
background color is a dark tan.
Comment 8 Máirín Duffy 2006-01-12 11:39:30 EST
ok, checked the fix into release-4.0 and head.

TEST PLAN
=========

Notes: this affects hosted & satellite; might want to try it on a couple of
different system profiles with different hardware

1) View a system profile and click on its "hardware" tab.
2) Verify that the headers for each column in the page's tables are readable and
that the data for each column is aligned underneath the header for that column.
Comment 9 Vlady Zlatkin 2006-02-13 17:25:06 EST
<vzlatkin> mizmo, so you just want me to fails_qa it?
<mizmo> vzlatkin: yeh, the problem with it is that it's making all the lists in
the site not line up properly, it's really subtle but annoying, im working on a
fix now
Comment 10 Máirín Duffy 2006-02-13 17:35:09 EST
Created attachment 124583 [details]
busted css example
Comment 11 Máirín Duffy 2006-02-13 17:35:34 EST
Created attachment 124584 [details]
the way it should look
Comment 12 Máirín Duffy 2006-02-13 18:38:27 EST
Just checked in the fix for this into release-4.0 (406) and head; will move back
to on_qa after the next push.
Comment 13 Máirín Duffy 2006-02-16 19:49:02 EST
Moving back to on_qa - same test plan as in comment 8 except! make sure all the
other lists across the UI aren't busticated as shown in the attachment in
comment 10. :)
Comment 14 Vlady Zlatkin 2006-02-17 12:40:53 EST
looks good
Comment 15 Vlady Zlatkin 2006-03-03 18:09:36 EST
verified in stage, and verified content of satellite to match previously blessed
content
Comment 16 Todd Warner 2006-03-15 14:34:14 EST
Closing upon release of RHN 406

Note You need to log in before you can comment on or make changes to this bug.