Bug 1463617 - right-click menu copy & paste is gray and disabled in import YAML/JSON ace editor in the chrome 59 browser.
right-click menu copy & paste is gray and disabled in import YAML/JSON ace e...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.9.0
Assigned To: Jessica Forrester
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 06:37 EDT by xipang
Modified: 2018-03-28 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The ACE editor library contained bugs in certain browsers when trying to use the right click copy and paste functions. Consequence: Users were not consistently able to use the right click menu to copy and paste text from the Edit YAML, Jenkinsfile editor, Dockerfile editor, and any other places the ACE editor was being used. Fix: A newer version of ACE editor is being used. Result: Right click copy and paste now works across browsers throughout the console.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-28 10:05:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 10:05 EDT

  None (edit)
Description xipang 2017-06-21 06:37:50 EDT
Description of problem:
right-click menu copy & paste is gray and disabled in import YAML/JSON ace editor in the chrome 59 browser.However,can use Ctrl+C & Ctrl+V.
Friefox does not have the issue

Version-Release number of selected component (if applicable):
openshift v3.6.121
kubernetes v1.6.1+5115d708d7


How reproducible:
Always

Steps to Reproduce:
1.Login and create a project
2.Click Add to Project and Select Import YAML/JSON
3.Open your local files manager, copy in file pv.json to the
editor

Actual results:
3.Cannot right-click to paste

Expected results:
3.Successlly paste content 

Additional info:
Comment 1 Jessica Forrester 2017-06-21 09:02:36 EDT
This is a known issue with the underlying ACE editor, also see https://github.com/openshift/origin-web-console/issues/1085
Comment 2 Jessica Forrester 2017-11-01 14:54:53 EDT
this is fixed in ace-builds 1.2.9, we'll update once branches open for the next release since its a big jump
Comment 3 Jessica Forrester 2017-12-14 14:30:31 EST
This was fixed in https://github.com/openshift/origin-web-console/pull/2570
Comment 5 yapei 2018-01-03 20:55:47 EST
Tested on v3.9.0-0.9.0

Right click menu Copy & Paste works in ace-editor on Chrome 63
Comment 8 errata-xmlrpc 2018-03-28 10:05:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489

Note You need to log in before you can comment on or make changes to this bug.