Bug 1463625 - Fail to create an instance with containerized compute
Fail to create an instance with containerized compute
Status: CLOSED DUPLICATE of bug 1459592
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Eoghan Glynn
Joe H. Rahme
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 07:18 EDT by Jean-Francois Saucier
Modified: 2017-06-23 05:32 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 05:26:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nova-compute log from the compute (337.51 KB, text/plain)
2017-06-21 07:18 EDT, Jean-Francois Saucier
no flags Details

  None (edit)
Description Jean-Francois Saucier 2017-06-21 07:18:21 EDT
Created attachment 1290022 [details]
nova-compute log from the compute

Description of problem:

I build a containerized OSP-12 deployment (1 controller, 1 compute) using the latest 12 rhos-release yesterday (2017-06-19.1 branch). My cluster seems to run fine but when I try to create an instance, it fail with the error : "No valid host was found. There are not enough hosts available."

However, the real error on the computer node seems to be : "libvirt:  error : Unable to move /dev/log mount to /var/run/libvirt/qemu/instance-00000001.log: No such file or directory"


Version-Release number of selected component (if applicable):

openstack-nova-common-16.0.0-0.20170609171025.el7ost.noarch
python-novaclient-9.0.0-0.20170609003607.7585703.el7ost.noarch


How reproducible:

Everytime I try to create or launch an instance.


Steps to Reproduce:
1. Install a containerized deployment using the latest 12 rhos-release
2. Try to create an instance


Actual results:

The instance creation fail.


Expected results:

The instance start normally.
Comment 1 Sven Anderson 2017-06-23 05:26:20 EDT

*** This bug has been marked as a duplicate of bug 1459592 ***

Note You need to log in before you can comment on or make changes to this bug.