Bug 14637 - Unresolved Symbols
Unresolved Symbols
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 14635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-25 16:32 EDT by Brian Highers
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-25 16:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Highers 2000-07-25 16:32:32 EDT
Making an initrd images with a new module set is giving me several lines 
of unresolved symbols that it is looking for in the /lib/modules/2.2.14-
5.0smp directory.  I renamed the file /usr/src/linux/include/linux/modules 
to ../modules.old and made a new empty directory called modules. I made a 
new directory in /lib/modules and changed the extraversion line in the 
Makefile in /usr/src/linux to put the new modules in the newly created 
directory in /lib/modules.  I ran mkinitrd with the new modules and 
everything boots ok except for the 'depmod' errors from 
the /lib/modules/2.2.14-5.0smp.  I notice that the file modules.dep gets 
written to this directory even once it is removed.  I am curious what is 
going on during boot time that is pointing to that directory even though I 
have booted a kernel with an initrd that excludes that directory.

Brian Highers
American Megatrends
Comment 1 Bill Nottingham 2001-07-06 18:49:36 EDT
It's using the compiled in version; if you didn't change that in the
kernel image, it will still look there.
Comment 2 Bill Nottingham 2001-07-06 18:49:55 EDT
*** Bug 14635 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.