Bug 1463705 - RAID RESHAPE: enable on in-use LVs
RAID RESHAPE: enable on in-use LVs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.5
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Heinz Mauelshagen
cluster-qe@redhat.com
:
Depends On: 1447812 1492250 1506342
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 10:18 EDT by Heinz Mauelshagen
Modified: 2018-04-10 11:21 EDT (History)
11 users (show)

See Also:
Fixed In Version: lvm2-2.02.175-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1447812
Environment:
Last Closed: 2018-04-10 11:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0853 None None None 2018-04-10 11:21 EDT

  None (edit)
Comment 3 Heinz Mauelshagen 2017-06-21 10:24:01 EDT
We disabled reshaping of in-use RaidLVs in RHEL7.4 as of bz1447812 because of a potential data corruption on reshaping striped RAIDs.

This bz tracks enabling it again once the deadlock fix is in.
Comment 4 Jonathan Earl Brassow 2017-06-21 12:33:23 EDT
... but the increased functionality is scheduled for 7.5 and is not a testblocker.
Comment 7 Marian Csontos 2017-10-10 08:31:35 EDT
Heinz, is the deadlock fix mentioned in Comment 3 in? Should this be reenabled and tested?
Comment 8 Heinz Mauelshagen 2017-10-11 09:12:52 EDT
(In reply to Marian Csontos from comment #7)
> Heinz, is the deadlock fix mentioned in Comment 3 in? Should this be
> reenabled and tested?

Yes.

LVM2 enabled reshaping of in-use LV again with
commit 6685460f5a918393edcde50d11f5cefb3a259df8.
Comment 12 Corey Marthaler 2017-11-27 15:48:56 EST
Verified that online in-use reshape/takeover is again enabled in the latest lvm rpms. 

3.10.0-799.el7.x86_64
lvm2-2.02.176-4.el7    BUILT: Wed Nov 15 04:21:19 CST 2017


That said the following 7.4 issues are again back as 7.5 regressions.

bug 1514539 kernel Deadlock in reshape on single core machine
bug 1514500 kernel RAID TAKEOVER: "divide error" panic during raid0_meta -> raid10 attempt
bug 1514215 lvm2   RAID RESHAPE: potential for data corruption when adding striped raid images to offline volumes
Comment 15 errata-xmlrpc 2018-04-10 11:20:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0853

Note You need to log in before you can comment on or make changes to this bug.