Bug 1463749 - powerpc-utils pulls Perl into the base-runtime on ppc64[le] systems
powerpc-utils pulls Perl into the base-runtime on ppc64[le] systems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: powerpc-utils (Show other bugs)
26
ppc64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vasant Hegde
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2017-06-21 12:07 EDT by Stephen Gallagher
Modified: 2017-11-15 12:39 EST (History)
13 users (show)

See Also:
Fixed In Version: powerpc-utils-1.3.4-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-15 12:39:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2017-06-21 12:07:06 EDT
Description of problem:
The Fedora base-runtime includes ppc64-utils because it is apparently needed to boot a ppc64 or ppc64le system to Fedora. (I say apparently, because we are mostly trusting that the Fedora lorax template[1] is correct, which lists it)

However, ppc64-utils requires powerpc-utils which includes a dependency on Perl to support /sbin/rtas_dump and /sbin/hvcsadmin. We do not want to pull Perl into the base-runtime (because we would have to maintain it with the base-runtime's lifecycle).

It's possible that these utilities are not in fact needed for installation or booting, in which case we'll just drop them from the base-runtime. However, if they are needed (such as during initramfs creation or something), we need to figure out if we can split out those two executables into a subpackage to avoid pulling in Perl.


Version-Release number of selected component (if applicable):
powerpc-utils-1.3.3-1.fc26


Additional info:

[1] https://github.com/rhinstaller/lorax/blob/master/share/templates.d/99-generic/runtime-install.tmpl
Comment 1 Fedora Update System 2017-10-10 11:38:29 EDT
powerpc-utils-1.3.4-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3affdadfbc
Comment 2 Fedora Update System 2017-10-11 02:29:40 EDT
powerpc-utils-1.3.4-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3affdadfbc
Comment 3 Fedora Update System 2017-10-11 11:28:25 EDT
powerpc-utils-1.3.4-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3affdadfbc
Comment 4 Fedora Update System 2017-10-13 02:22:45 EDT
powerpc-utils-1.3.4-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3affdadfbc
Comment 5 Fedora Update System 2017-11-15 12:39:47 EST
powerpc-utils-1.3.4-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.