Bug 1463774 - [3.3] The installer should allow for redeploy of etcd CA only.
[3.3] The installer should allow for redeploy of etcd CA only.
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.3.1
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.1
Assigned To: Andrew Butcher
Gaoyun Pei
:
Depends On: 1451927 1463775
Blocks: 1463772 1463773
  Show dependency treegraph
 
Reported: 2017-06-21 13:58 EDT by Andrew Butcher
Modified: 2017-06-29 09:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1451927
Environment:
Last Closed: 2017-06-29 09:34:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Gaoyun Pei 2017-06-27 04:19:27 EDT
Test this bug with openshift-ansible-3.3.100-1.git.0.5fe2079.el7.noarch

[root@gpei-test-ansible bz1463774]# ansible-playbook -i host -v /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/redeploy-etcd-ca.yml 
Using /etc/ansible/ansible.cfg as config file
ERROR! the role 'openshift_etcd_ca' was not found in /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/../../common/openshift-cluster/redeploy-certificates/roles:/etc/ansible/roles:/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/../../common/openshift-cluster/redeploy-certificates

The error appears to have been in '/usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/redeploy-certificates/etcd-ca.yml': line 40, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  roles:
  - role: openshift_etcd_ca
    ^ here
Comment 7 Gaoyun Pei 2017-06-27 23:27:45 EDT
Verify this bug with openshift-ansible-3.3.102-1.git.0.7983529.el7.noarch

For Etcd CA cert redeployment, we could use playbook /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/redeploy-etcd-ca.yml

This playbook will only create new etcd CA certificate, then distribute etcd CA to etcd hosts and masters, restart etcd and master services.


For openshift CA cert redeployment, we could use playbook
/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/redeploy-openshift-ca.yml

This playbook will only create new OpenShift CA certificate, then distribute new CA cert to masters and nodes, restart master and node services.
Comment 9 errata-xmlrpc 2017-06-29 09:34:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1666

Note You need to log in before you can comment on or make changes to this bug.