Bug 1463809 - Need ability to completely disable goferd on managed clients
Need ability to completely disable goferd on managed clients
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.2.9
x86_64 Linux
urgent Severity urgent (vote)
: Beta
: --
Assigned To: satellite6-bugs
Roman Plevka
: PrioBumpField, PrioBumpGSS, Triaged
Depends On: 1454352 1463818
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 15:39 EDT by pm-sat@redhat.com
Modified: 2018-02-21 07:57 EST (History)
16 users (show)

See Also:
Fixed In Version: tfm-rubygem-katello-3.4.1
Doc Type: Enhancement
Doc Text:
You can now manage clients without goferd. This limits the host management functionality only to uploading the package profile after installing, removing, updating packages, and triggering the Satellite tasks such as the applicable errata.
Story Points: ---
Clone Of: 1445403
Environment:
Last Closed: 2018-02-21 07:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 19393 None None None 2017-06-21 15:39 EDT

  None (edit)
Comment 2 Roman Plevka 2017-09-28 06:50:29 EDT
VERIFIED
on sat6.3.0-17

el7,el6 and el5 satellite-tools repository now contain the katello-host-tools package, which contains the yum package profile update plugin.

- This package does not contain the gofer component, so there is no goferd running while using this setup, limiting the host management functionality to only uploading the package profile after installing/removing/updating packages and successfully triggers the satellite tasks, such as 'errata applicability', etc.
in order to trigger the package, pgroup, errata installation, etc. one is able to use REX via SSH.
Comment 3 Djebran Lezzoum 2017-11-21 09:51:50 EST
qe_test_coverage PR: https://github.com/SatelliteQE/robottelo/pull/5549
Comment 6 errata-xmlrpc 2018-02-21 07:57:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0338

Note You need to log in before you can comment on or make changes to this bug.