Bug 1463819 - Orphaned qpid journal files when unregistering a content host
Orphaned qpid journal files when unregistering a content host
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Qpid (Show other bugs)
6.2.8
x86_64 Linux
high Severity high (vote)
: GA
: --
Assigned To: Mike Cressman
Radovan Drazny
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 15:42 EDT by pm-sat@redhat.com
Modified: 2018-02-21 07:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1443470
Environment:
Last Closed: 2018-02-21 07:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-7788 None None None 2017-06-21 15:42 EDT

  None (edit)
Comment 2 Radovan Drazny 2017-09-20 09:25:02 EDT
Verified on Satellite 6.3, qpid-cpp-server-1.36.0-9.el7 using the reproducer from the original report. 

On a Satellite client the following loop was running:

while true; 
do 
  subscription-manager register --org="Default_Organization" --username=admin --password=nimda 
  sleep 5
  systemctl restart goferd
  sleep 5
  subscription-manager unregister
done

Monitoring the /var/lib/qpidd/.qpidd/qls/p001/efp/2048k/in_use dir on the Sat 6.3 server using following commands:

ls in_use | wc -l
du -ks in_use

The directory wasn't completely stable, but the number of files and present and consumed disk space always went down after a short (and not too high) spike, so qpid server was cleaning up old files and not leaving orphans. 

VERIFIED
Comment 5 errata-xmlrpc 2018-02-21 07:57:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0338

Note You need to log in before you can comment on or make changes to this bug.