Bug 1463839 - LibreOffice Draw crash on document save on F25 due to missing dependencies
LibreOffice Draw crash on document save on F25 due to missing dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 17:09 EDT by Aissen
Modified: 2017-07-14 14:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: libreoffice-5.3.4.2-3.fc26 libreoffice-5.2.7.2-5.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 09:23:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdbtrace.log of soffice --backtrace first with gtk3, then gtk2 (14.06 KB, text/plain)
2017-06-21 17:09 EDT, Aissen
no flags Details
Screen capture of the issue (74.92 KB, image/png)
2017-06-22 12:35 EDT, Aissen
no flags Details

  None (edit)
Description Aissen 2017-06-21 17:09:37 EDT
Created attachment 1290316 [details]
gdbtrace.log of soffice --backtrace first with gtk3, then gtk2

Description of problem:


Version-Release number of selected component (if applicable):
1:5.2.7.2-3.fc25

How reproducible:
always

Steps to Reproduce:
1. Launch libreoffice draw on F25 Plasma Desktop
2. Try to save a document (even empty)
3.

Actual results:

It fails saying "Error saving the document Untitled1:
General Error.
General input/output error."

You then can't use libreoffice anymore.


Expected results:
It saves a document.


Additional info:
$ dnf list installed libreoffice*                           
libreoffice-calc.x86_64                                        1:5.2.7.2-3.fc25                             @updates
libreoffice-core.x86_64                                        1:5.2.7.2-3.fc25                             @updates
libreoffice-data.noarch                                        1:5.2.7.2-3.fc25                             @updates
libreoffice-draw.x86_64                                        1:5.2.7.2-3.fc25                             @updates
libreoffice-graphicfilter.x86_64                               1:5.2.7.2-3.fc25                             @updates
libreoffice-gtk2.x86_64                                        1:5.2.7.2-3.fc25                             @updates
libreoffice-gtk3.x86_64                                        1:5.2.7.2-3.fc25                             @updates
libreoffice-langpack-en.x86_64                                 1:5.2.7.2-3.fc25                             @updates
libreoffice-langpack-fr.x86_64                                 1:5.2.7.2-3.fc25                             @updates
libreoffice-opensymbol-fonts.noarch                            1:5.2.7.2-3.fc25                             @updates
libreoffice-pdfimport.x86_64                                   1:5.2.7.2-3.fc25                             @updates
libreoffice-pyuno.x86_64                                       1:5.2.7.2-3.fc25                             @updates
libreoffice-ure.x86_64                                         1:5.2.7.2-3.fc25                             @updates
libreoffice-ure-common.noarch                                  1:5.2.7.2-3.fc25                             @updates
libreoffice-writer.x86_64                                      1:5.2.7.2-3.fc25                             @updates
libreoffice-x11.x86_64                                         1:5.2.7.2-3.fc25                             @updates

I have this trace in xsession-errors/console:
(soffice:32612): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed

I thought it was linked to gtk3, so I used SAL_USE_VCLPLUGIN=gtk but then it still "crashes", but without the aforementioned trace.

Note that Calc/Writer are fine and can save documents.
Comment 1 Caolan McNamara 2017-06-22 04:43:41 EDT
This can't be a general problem or we'd be inundated with bug reports that draw fails, so there must be something specific about your setup. Like your disk is full or the installation is broken
Comment 2 Aissen 2017-06-22 09:54:05 EDT
I'm inclined to believe you. But:
 - it happens on two distinct machines, with more than enough free space on disk. Both were upgraded from F24 though.

 - I use KDE/Plasma desktop. This isn't the default F25 install

 - I have tried removing my profile (mv ~/.config/libreoffice/4 4.bak), I still reproduce.

I have run "rpm -Va --nomtime" to verify the installed packages, and haven't seen any significant modification. So what do you suggest I try ?
Comment 3 Caolan McNamara 2017-06-22 12:26:42 EDT
There's no hint in the backtrace, except SIGINT, which more suggests that it was interrupted with ctrl+c, so there's no actual crash recorded in the bt so its hard to figure what the problem might be
Comment 4 Aissen 2017-06-22 12:35 EDT
Created attachment 1290771 [details]
Screen capture of the issue

Ok, so I bit the bullet, and did a clean install of F25 KDE spin in a VM, created a new user, and I was able to reproduce the problem.

So this is a clean system, nothing specific to my install. I just updated all the packages (dnf update) and installed the libreoffice-draw package.
Comment 5 Caolan McNamara 2017-06-23 06:32:37 EDT
Does it make a difference to enable tools->options->general->use libreoffice dialogs and then try to save ?


what is the output of

locale

?
Comment 6 Aissen 2017-06-23 08:25:18 EDT
locale:
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Libreoffice dialogs: it still outputs the same General Error.
Comment 7 Aissen 2017-06-23 08:42:10 EDT
I moved the user to "en_US.UTF-8", it still errors.

I tried launching with "LANG=C soffice", the issue is still here.
Comment 8 Aissen 2017-06-28 12:38:13 EDT
I just tested a clean install of F26 KDE spin, same issue after a dnf update.
Comment 9 Aissen 2017-07-09 12:06:13 EDT
I finally found the source of the bug. libreoffice-draw depends on libreoffice-impress.

Impress was not installed as you can see in the bug report, and I didn't install it either in my subsequent tests in a VM. I did a final test today, this time installing F26 Workstation, then @kde-desktop. When launching a Plasma session, LibreOffice Draw then works properly. So I compared the list of installed packages, and it turns out that they are a few more packages. libreoffice-filters pulled some packages I didn't have. I tested them one by one, and it turns out that libreoffice-impress is the source of this issue.

I see a way forward by adding a dependency from libreoffice-draw either to libreoffice-filters or libreoffice-impress.
Comment 10 Caolan McNamara 2017-07-10 06:09:35 EDT
caolanm->dtardon: can you see why that dependency is an issue and what the right fix is
Comment 11 Fedora Update System 2017-07-12 01:27:25 EDT
libreoffice-5.3.4.2-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-113b0cbdd3
Comment 12 Fedora Update System 2017-07-12 01:27:44 EDT
libreoffice-5.2.7.2-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ddbfbff881
Comment 13 Aissen 2017-07-12 09:44:33 EDT
I confirm the new package fixes the issue on F26.
Comment 14 Aissen 2017-07-12 09:55:29 EDT
For completeness, I also tested libreoffice-impress without libreoffice-draw installed. Just saving a file works, but I didn't do much more.
Comment 15 Fedora Update System 2017-07-12 12:24:59 EDT
libreoffice-5.2.7.2-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ddbfbff881
Comment 16 Fedora Update System 2017-07-12 14:22:22 EDT
libreoffice-5.3.4.2-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-113b0cbdd3
Comment 17 Fedora Update System 2017-07-14 09:23:39 EDT
libreoffice-5.3.4.2-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2017-07-14 14:22:20 EDT
libreoffice-5.2.7.2-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.