Bug 1463882 - [abrt] BUG: unable to handle kernel NULL pointer dereference at (null)
[abrt] BUG: unable to handle kernel NULL pointer dereference at (null)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:94b91133e1b6aaba206aa027f50...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 22:11 EDT by Eduardo Habkost
Modified: 2017-06-26 22:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 08:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (61.09 KB, text/plain)
2017-06-21 22:12 EDT, Eduardo Habkost
no flags Details

  None (edit)
Description Eduardo Habkost 2017-06-21 22:11:47 EDT
Description of problem:
Machine was unattended compiling software (make -j4). Got back a few hours later, found it unresponsive.

Additional info:
reporter:       libreport-2.8.0
BUG: unable to handle kernel NULL pointer dereference at           (null)
IP: [<ffffffffbb11c983>] timecounter_read+0x13/0x60
PGD 0 
Oops: 0000 [#1] SMP
Modules linked in: tun tcp_diag udp_diag inet_diag unix_diag fuse nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT xt_mac ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_mangle ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_mangle iptable_security ebtable_filter ebtables ip6table_filter ip6_tables bnep arc4 snd_soc_skl snd_soc_skl_ipc snd_soc_sst_ipc intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp snd_soc_sst_dsp snd_hda_ext_core snd_soc_sst_match snd_soc_core kvm_intel snd_hda_codec_hdmi snd_compress snd_pcm_dmaengine snd_hda_codec_realtek kvm snd_hda_codec_generic
 ac97_bus iwlmvm snd_hda_intel mac80211 mei_wdt iTCO_wdt iTCO_vendor_support irqbypass snd_hda_codec vfat intel_cstate fat intel_uncore snd_hda_core iwlwifi snd_hwdep snd_seq intel_rapl_perf uvcvideo snd_seq_device videobuf2_vmalloc snd_pcm btusb cfg80211 videobuf2_memops btrtl videobuf2_v4l2 btbcm btintel videobuf2_core bluetooth videodev joydev snd_timer mei_me i2c_i801 i2c_smbus thinkpad_acpi media rtsx_pci_ms memstick snd mei shpchp intel_pch_thermal soundcore wmi rfkill tpm_crb tpm_tis tpm_tis_core tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc dm_crypt i915 rtsx_pci_sdmmc mmc_core crct10dif_pclmul crc32_pclmul crc32c_intel e1000e ghash_clmulni_intel i2c_algo_bit ptp drm_kms_helper pps_core serio_raw drm rtsx_pci video fjes
CPU: 2 PID: 7933 Comm: kworker/2:2 Not tainted 4.8.6-300.fc25.x86_64 #1
Hardware name: LENOVO 20FM0007BR/20FM0007BR, BIOS R06ET48W (1.22 ) 02/20/2017
Workqueue: events e1000e_systim_overflow_work [e1000e]
task: ffff9a8a3ea31f00 task.stack: ffff9a8a3db10000
RIP: 0010:[<ffffffffbb11c983>]  [<ffffffffbb11c983>] timecounter_read+0x13/0x60
RSP: 0018:ffff9a8a3db13da8  EFLAGS: 00010046
RAX: 0000000000000000 RBX: ffff9a8a49f9f7d8 RCX: dead000000000200
RDX: 0000000000000001 RSI: ffff9a8a3db13df0 RDI: 0000000000000000
RBP: ffff9a8a3db13db0 R08: ffff9a8a49f9f718 R09: 0000000000000000
R10: 0000000000006b3c R11: 0000000000013a85 R12: ffff9a8a49f9f7b8
R13: ffff9a8a3db13df0 R14: 0000000000000246 R15: ffff9a8a49f9f710
FS:  0000000000000000(0000) GS:ffff9a8a61480000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000000000000 CR3: 0000000005e06000 CR4: 00000000003406e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Stack:
 ffff9a8a49f9f808 ffff9a8a3db13de0 ffffffffc03b43de ffff9a8a49f9f710
 ffff9a8a61498d80 ffff9a8a6149d700 ffff9a8a49f9f718 ffff9a8a3db13e10
 ffffffffc03b45a1 ffffffffbb7fd932 00ff9a89721be3c0 000000006062cfdc
Call Trace:
 [<ffffffffc03b43de>] e1000e_phc_gettime+0x2e/0x60 [e1000e]
 [<ffffffffc03b45a1>] e1000e_systim_overflow_work+0x31/0xa0 [e1000e]
 [<ffffffffbb7fd932>] ? __schedule+0x2f2/0x770
 [<ffffffffbb0baa74>] process_one_work+0x184/0x430
 [<ffffffffbb0bad6e>] worker_thread+0x4e/0x480
 [<ffffffffbb0bad20>] ? process_one_work+0x430/0x430
 [<ffffffffbb0c0c08>] kthread+0xd8/0xf0
 [<ffffffffbb80277f>] ret_from_fork+0x1f/0x40
 [<ffffffffbb0c0b30>] ? kthread_worker_fn+0x180/0x180
Code: 00 48 d3 e0 48 83 e8 01 48 89 43 18 5b 41 5c 41 5d 5d c3 0f 1f 44 00 00 0f 1f 44 00 00 55 48 89 e5 53 48 8b 07 48 89 fb 48 89 c7 <ff> 10 48 8b 0b 48 89 c2 48 2b 53 08 8b 71 10 48 23 51 08 48 0f 
RIP  [<ffffffffbb11c983>] timecounter_read+0x13/0x60
 RSP <ffff9a8a3db13da8>
CR2: 0000000000000000
Comment 1 Eduardo Habkost 2017-06-21 22:12:00 EDT
Created attachment 1290421 [details]
File: dmesg
Comment 2 Josh Boyer 2017-06-26 08:57:42 EDT
4.8.6 is no longer supported.  Please update and reopen if you hit this issue on 4.11.6 or newer.
Comment 3 Eduardo Habkost 2017-06-26 22:18:54 EDT
For reference, the system didn't crash since I updated the kernel 5 days ago.

Note You need to log in before you can comment on or make changes to this bug.