Bug 1463917 - value of disk type is set as raid6 even if raid5 is chosen from cockpit UI
value of disk type is set as raid6 even if raid5 is chosen from cockpit UI
Status: CLOSED CURRENTRELEASE
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy (Show other bugs)
0.10.7-0.0.20
x86_64 Linux
unspecified Severity medium
: ovirt-4.1.7
: 0.10.8-2.2
Assigned To: Gobinda Das
SATHEESARAN
:
Depends On:
Blocks: Gluster-HC-3
  Show dependency treegraph
 
Reported: 2017-06-22 02:25 EDT by RamaKasturi
Modified: 2017-11-13 07:29 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.10.8-2.2.ovirt41
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-13 07:29:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sasundar: ovirt‑4.1?
sasundar: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81646 master POST Allowing user to select any disk type and creating gdeploy config file 2017-09-12 02:46 EDT
oVirt gerrit 81755 ovirt-4.1 POST Allowing user to select any disk type and creating gdeploy config file 2017-09-14 08:04 EDT
oVirt gerrit 82382 ovirt-4.2 MERGED Allowing user to select any disk type and creating gdeploy config file 2017-09-29 08:39 EDT

  None (edit)
Description RamaKasturi 2017-06-22 02:25:07 EDT
Description of problem:
value of disk type is set as 'raid6' in the generated gdeploy config file even if the value selected using gui is 'raid5'

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.20.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install latest ovirt-cockpit-dashboard
2. select 'configure gluster'
3. Now select the disk type as 'raid5'
4. proceed till generation of conf file.

Actual results:
Even thought the disk type is selected as 'raid5' in the generated gdeploy conf it is set as 'raid6'

Expected results:
When the disk type is selected as 'raid5' generated gdeploy conf file should also have the disk type as 'raid5'

Additional info:

This issue was found by one of the community user and i am logging it on behalf of him.
Comment 1 RamaKasturi 2017-06-22 02:25:32 EDT
comments from him:
========================
I had to manually change the install script to RAID5 even if it is chosen in the gui (sets RAID6 in the script).
Comment 2 SATHEESARAN 2017-06-23 03:29:20 EDT
disktype as 'raid5' or 'raid5' has the same effect on the calculation of LVM parameters, as the 'diskcount' always amounts to data disks only ( which are non parity ones )

So technically disktype as 'raid5' or 'raid6' doesn't have any difference at all , and that's the reason even when disktype is selected as 'raid5' from cockpit, the generated gdeploy conf file always has 'raid6'.
Comment 3 SATHEESARAN 2017-06-23 03:30:39 EDT

(In reply to RamaKasturi from comment #1)
> comments from him:
> ========================
> I had to manually change the install script to RAID5 even if it is chosen in
> the gui (sets RAID6 in the script).

He need not change it to raid5 in the install script, he can just carry on with raid6 and that will not cause him any problem.
Comment 4 SATHEESARAN 2017-06-23 03:32:12 EDT
(In reply to SATHEESARAN from comment #2)
> disktype as 'raid5' or 'raid5' 

Typo here, I meant that LVM parameters are agnostic to RAID types ( raid5 or raid6 )
Comment 5 RamaKasturi 2017-06-23 05:05:27 EDT
(In reply to RamaKasturi from comment #1)
> comments from user:
> ========================
> I had to manually change the install script to RAID5 even if it is chosen in
> the gui (sets RAID6 in the script).
Comment 6 RamaKasturi 2017-06-23 05:08:27 EDT
(In reply to SATHEESARAN from comment #4)
> (In reply to SATHEESARAN from comment #2)
> > disktype as 'raid5' or 'raid5' 
> 
> Typo here, I meant that LVM parameters are agnostic to RAID types ( raid5 or
> raid6 )

Agree with you on this. That is the same thing which was explained to the user as well. 

I feel that when raid5 is selected in the UI, irrespective of what we do underneath we should always put it as 'raid5' in the conf file too.
Comment 7 Laura Bailey 2017-06-29 00:22:22 EDT
Agree with Kasturi; leaving this as raid6 in the config file is confusing for users.
Comment 8 Sahina Bose 2017-09-12 09:20:16 EDT
(In reply to RamaKasturi from comment #6)
> (In reply to SATHEESARAN from comment #4)
> > (In reply to SATHEESARAN from comment #2)
> > > disktype as 'raid5' or 'raid5' 
> > 
> > Typo here, I meant that LVM parameters are agnostic to RAID types ( raid5 or
> > raid6 )
> 
> Agree with you on this. That is the same thing which was explained to the
> user as well. 
> 
> I feel that when raid5 is selected in the UI, irrespective of what we do
> underneath we should always put it as 'raid5' in the conf file too.

The reason why RAID5 was not passed to gdeploy is because gdeploy did not have support for this RAID type. Has this changed?
Comment 9 Sahina Bose 2017-09-12 09:28:03 EDT
Clearing needinfo as Sac confirmed that gdeploy now supports raid5 disktype
Comment 10 Sandro Bonazzola 2017-10-11 07:12:36 EDT
Should be in oVirt 4.1.7 RC3
Comment 11 RamaKasturi 2017-10-12 06:51:11 EDT
Verified and works fine with build cockpit-ovirt-dashboard-0.10.8-2.2.ovirt41.el7ev.noarch.

When the Raid Type is chosen as 'RAID5' in gdeploy wizard, generated gdeploy conf file has the same value.

Note You need to log in before you can comment on or make changes to this bug.