Bug 146394 - Applications that use old glob function could crash on Alpha
Applications that use old glob function could crash on Alpha
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
3
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 15:37 EST by Sergey Tikhonov
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 17:01:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to fix the problem (408 bytes, patch)
2005-01-27 15:38 EST, Sergey Tikhonov
no flags Details | Diff

  None (edit)
Description Sergey Tikhonov 2005-01-27 15:37:29 EST
Description of problem:
The problem occured while trying to use "yum" (actually some rpm
library for python) on linux/alpha.
The problem is that old_globfree function for Alpha didn't copied all
necessary fields to new glob structure and called new "globfree"
function with garbage in "gl_offs" field.

Version-Release number of selected component (if applicable):
glibc-2.3.4-3.fc3

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sergey Tikhonov 2005-01-27 15:38:51 EST
Created attachment 110317 [details]
Proposed patch to fix the problem

The patch copied gl_offs field from old structure
Comment 2 Ulrich Drepper 2005-01-27 15:52:55 EST
Committed to upstream CVS.

Note You need to log in before you can comment on or make changes to this bug.