Bug 1463967 - chrome-remote-desktop creates a conflicting directory symlink
chrome-remote-desktop creates a conflicting directory symlink
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chromium (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 03:30 EDT by Pete Walter
Modified: 2017-07-18 02:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 17:05:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Walter 2017-06-22 03:30:13 EDT
I am working on a new package, chrome-gnome-shell. It uses the native messaging hosts interface and installs files in /etc/opt/chrome/native-messaging-hosts/ directory. When chrome-remote-desktop is installed we get a file conflict as chrome-remote-desktop has replaced the directory with a symlink. This is caused by the following lines in chromium.spec:

pushd %{buildroot}%{_sysconfdir}/opt/chrome/
ln -s ../../chromium/native-messaging-hosts native-messaging-hosts
popd

Please remove this so that other programs can also use the directory. Thanks.


$ sudo dnf install chrome-remote-desktop-56.0.2924.87-3.fc25.x86_64 
...
Error: Transaction check error:
  file /etc/opt/chrome/native-messaging-hosts from install of chrome-remote-desktop-56.0.2924.87-3.fc25.x86_64 conflicts with file from package chrome-gnome-shell-8.2-1.fc25.noarch
Comment 1 Tom "spot" Callaway 2017-06-22 13:19:41 EDT
Easy enough. I'll change it to be a dir rather than a symlink. You might also consider ensuring that your files are visible from both paths:

/etc/opt/chrome/native-messaging-hosts
/etc/chromium/native-messaging-hosts

That should ensure that your code works with both Google Chrome and Chromium (as packaged in Fedora).
Comment 2 Tom "spot" Callaway 2017-07-17 17:05:42 EDT
This should be fixed now in rawhide.
Comment 3 Pete Walter 2017-07-18 02:47:32 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.