Bug 1463971 - [UI] - Cannot create new Host QoS entity via the DC flow
[UI] - Cannot create new Host QoS entity via the DC flow
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
high Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Andrej Krejcir
Jan Zmeskal
: Regression
: 1508405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 03:51 EDT by Michael Burman
Modified: 2017-12-20 06:44 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:44:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
ui log (25.10 KB, application/x-gzip)
2017-06-22 03:51 EDT, Michael Burman
no flags Details
QoS (132.41 KB, image/png)
2017-11-21 07:59 EST, Jan Zmeskal
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 83472 master MERGED webadmin: Fix NPE when opening QoS dialog from DataCenter details tab. 2017-11-02 09:34 EDT

  None (edit)
Description Michael Burman 2017-06-22 03:51:55 EDT
Created attachment 1290537 [details]
ui log

Description of problem:
[UI] - Cannot create new Host QoS entity via the DC flow.

When trying to create new host QoS entity via the DC > Host QoS > new flow, nothing happens when pressing ok and ui exception appears in the webadmin portal, in ui.log is see:

2017-06-22 10:42:02,700+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-3) [] Permutation name: 9A60D1A15790BDED8BC80587283CD2E9
2017-06-22 10:42:02,700+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-3) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 'e' of undefined
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_131]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_131]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
        at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
        at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1415) [gwt-servlet.jar:]
        at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:312) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js)

When creating new Host QoS entity via the Networks > new Host QoS flow, everything working as it should and entity successfully created. 

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170621145605.git5e2dc4e.el7.cento

How reproducible:
100%

Steps to Reproduce:
1. Try to create new Host QoS from the DC

Actual results:
Nothing happens. ui exception in the ui.log

Expected results:
Should work as expected.
Comment 1 Michael Burman 2017-06-22 03:56:32 EDT
Same behaviour for STORAGE and VM QoS entities, but not for CPU.

Maybe it's should be moved to the UX team
Comment 2 Red Hat Bugzilla Rules Engine 2017-06-23 02:50:52 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Oved Ourfali 2017-07-19 08:33:09 EDT
Moving to SLA to check whether it works okay now, looking at all the flows.
Comment 4 Andrej Krejcir 2017-11-08 08:38:07 EST
*** Bug 1508405 has been marked as a duplicate of this bug. ***
Comment 5 Jan Zmeskal 2017-11-21 07:59 EST
Created attachment 1356671 [details]
QoS
Comment 6 Jan Zmeskal 2017-11-21 08:00:56 EST
Michael, I am not completely sure about the reproduction steps. Could you please take a look at the attached screenshot and verify if this is the flow you are refering to? Thank you.
Comment 7 Michael Burman 2017-11-21 08:06:33 EST
(In reply to Jan Zmeskal from comment #6)
> Michael, I am not completely sure about the reproduction steps. Could you
> please take a look at the attached screenshot and verify if this is the flow
> you are refering to? Thank you.

Hello Yan,
Yes, this is exactly the flow)
Comment 8 Sandro Bonazzola 2017-12-20 06:44:22 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.