Bug 1463983 - tasks and calendar are broken after updating to evolution-data-server-3.24.3-1.fc26.x86_64
tasks and calendar are broken after updating to evolution-data-server-3.24.3-...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
26
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 04:26 EDT by Christian Stadelmann
Modified: 2017-06-26 03:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 03:38:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2017-06-22 04:26:43 EDT
Version-Release number of selected component (if applicable):
evolution-data-server-3.24.3-1.fc26.x86_64
evolution-3.24.3-1.fc26.x86_64
gnome-todo-3.24.2-1.fc26.x86_64
gnome-calendar-3.24.3-1.fc26.x86_64
gnome-shell-3.24.2-1.fc26.x86_64

How reproducible:
unclear


Steps to Reproduce (calendar):
1. open evolution (calendar component), gnome-shell's calendar from top bar or gnome-calendar

Actual results:
no events are displayed. In evolution's status bar you can see that evolution tries to fetch the events, but it will never succeed in doing so.

Expected results:
show events


Steps to reproduce (tasks):
1. open evolution (tasks component) or gnome-todo

Actual results:
no tasks are displayed. In evolution's status bar you can see that evolution tries to fetch the tasks, but it will never succeed in doing so.

Expected results:
show tasks


Additional info:
Downgrading to evolution-data-server-3.24.2-2.fc26.x86_64 does work around this issue, there is no permanent data loss. You need to re-enable all the calendars and task lists though.
Comment 1 Milan Crha 2017-06-22 05:32:16 EDT
Thanks for a bug report. Did there happen a restart after you installed the new evolution-data-server, please? What are the calendars/tasks types you have configured, please? Like On This Computer/CalDAV/...

I tried it here too and neither before restart, not after it, there had been no issue. I had an On This Computer calendar and one calendar with few tasks lists configured through GNOME Online Accounts (addressing ownCloud, thus CalDAV).

Does your status bar show information about starting view, or about opening respective calendars? There are running several
evolution-calendar-factory-subporcess processes, each serving for one type of the calendar. If you install/update also the debuginfo package for
evolution-data-server, then getting a backtrace of one of them may give some hints of what it is stuck with. You can get the backtrace with command like this:
   $ gdb --batch --ex "t a a bt" -pid=PID &>bt.txt
Please check the bt.txt for any private information, like passwords, email address, server addresses,... I usually search for "pass" at least (quotes for clarity only).

The PID is replaced with the actual process ID, which you can obtain from a command like this:
   $ ps ax | grep evolution
which also shows the --factory parameter, which is a hint what calendar/book type the subprocess serves.
Comment 2 Christian Stadelmann 2017-06-23 09:42:02 EDT
(In reply to Milan Crha from comment #1)
> Thanks for a bug report. Did there happen a restart after you installed the
> new evolution-data-server, please?

Yes, I logged out, installed the updates from a TTY and shut down my computer. The problem occurred after next boot + login.

> What are the calendars/tasks types you
> have configured, please? Like On This Computer/CalDAV/...

On this computer, Birthday calendar, "On the web" (multiple instances, ICS or ICAL). Not configured through GOA.

I'll have a look at the rest later.
Comment 3 Christian Stadelmann 2017-06-23 09:58:44 EDT
After I hit the bug, I did a downgrade. Now I did an upgrade and restarted my computer and the problem is gone. I am unable to reproduce it any more.
Comment 4 Milan Crha 2017-06-26 03:38:22 EDT
Thanks for the update. The list of calendars you have configured is okay. If any of the On The Web calendars had been waiting for credentials (in case you've any which require it), then maybe it also blocked the other. It might not be the case for On This Computer calendars, though.

Pity you cannot reproduce it. As it begun to work again, I'm closing this bug report, but feel free to reopen in case you'd face it again, ideally with backtraces (see comment #1) to check what the processes do (debuginfo is important, for evolution-data-server is enough). Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.