Bug 1463989 - [RFE] Enable heketi (with inherent HA) running inside OCP to work with RHGS in CRS mode
[RFE] Enable heketi (with inherent HA) running inside OCP to work with RHGS i...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: CNS 3.6
Assigned To: Jose A. Rivera
Prasanth
:
Depends On:
Blocks: 1445444
  Show dependency treegraph
 
Reported: 2017-06-22 04:34 EDT by Prasanth
Modified: 2017-10-11 03:12 EDT (History)
10 users (show)

See Also:
Fixed In Version: cns-deploy-5.0.0-16
Doc Type: Enhancement
Doc Text:
With this update, cns-deploy is capable of deploying heketi inside Openshift to work with Red Hat Gluster Storage in a Container-Ready Storage environment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:12:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanth 2017-06-22 04:34:27 EDT
Description of problem:

As requested by PM in the last PgM meeting, we need a method / documented steps to enable heketi (with inherent HA) running inside OCP to work with RHGS in CRS mode. This BZ is created to track this request.
Comment 1 Prasanth 2017-06-22 04:39:02 EDT
Apart from the documented steps for manual deployment, shouldn't we also make the required code changes to implement the same in cns-deploy tool?
Comment 2 Michael Adam 2017-07-17 09:46:39 EDT
I think there are no changes required in QE.
The changes in OCP installer are already done.
Should we do the corresponding changes in cns-deploy?
(and hence change the component of this BZ...)
Comment 3 Michael Adam 2017-07-17 19:15:39 EDT
(In reply to Michael Adam from comment #2)
> I think there are no changes required in QE.

That should read "... in Heketi." :-)

> The changes in OCP installer are already done.

This is the main change:

https://github.com/openshift/openshift-ansible/commit/726dae9a3fa4b8e825387c39e2d5ef4a34095b7c

and here are some follow-up fixes currently under review:

https://github.com/openshift/openshift-ansible/pull/4769

> Should we do the corresponding changes in cns-deploy?
> (and hence change the component of this BZ...)

Today, we agreed on doing the changes in cns-deploy.
José is doing the changes.
Comment 4 Humble Chirammal 2017-07-24 14:10:18 EDT
CNS-deploy changes : https://github.com/gluster/gluster-kubernetes/pull/281
Comment 5 Humble Chirammal 2017-08-16 03:08:11 EDT
As the subjected Patch is merged in upstream , I moving this to MODIFIED.
Comment 6 Prasanth 2017-08-23 09:00:01 EDT
Moving this back to MODIFIED as the FIV build is broken and cannot be consumed for testing this feature.
Comment 9 Prasanth 2017-09-13 13:09:23 EDT
Verified as fixed
Comment 11 Raghavendra Talur 2017-10-10 03:22:19 EDT
I have made small change to doc text. Looks good to me.
Comment 13 errata-xmlrpc 2017-10-11 03:12:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2881

Note You need to log in before you can comment on or make changes to this bug.