Bug 1463996 - "KeyError: 'guestIds'" occurs after trigger guest when virt-who run against stage candlepin 2.0
"KeyError: 'guestIds'" occurs after trigger guest when virt-who run against s...
Status: CLOSED DUPLICATE of bug 1458674
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscriptions - virt-who (Show other bugs)
6.3.0
x86_64 Linux
high Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Tom McKay
Tom McKay
: Triaged
Depends On: 1458674
Blocks: 1462942
  Show dependency treegraph
 
Reported: 2017-06-22 04:56 EDT by Eko
Modified: 2017-07-25 06:21 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the virt-who service expected an outdated data format from the hypervisor check-ins. Consequently, virt-who in some cases failed to send the guest-hypervisor mappings and logged a "KeyError: 'guestIds'" message. The data format expected by virt-who has been updated, which prevents the described problem from occurring.
Story Points: ---
Clone Of: 1458674
Environment:
Last Closed: 2017-06-26 10:45:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github virt-who/virt-who/pull/75 None None None 2017-06-22 04:56 EDT

  None (edit)
Comment 1 Eko 2017-06-22 05:00:19 EDT
candlepin2.0 is used for satellite6.3.0, so this bug is blocked our testing.
Comment 2 Kevin Howell 2017-06-26 10:45:40 EDT
We'll track the work for this in bug 1458674

*** This bug has been marked as a duplicate of bug 1458674 ***

Note You need to log in before you can comment on or make changes to this bug.