This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 146400 - Support HD install from tree
Support HD install from tree
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 16:35 EST by Micah Parrish
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 17:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Micah Parrish 2005-01-27 16:35:05 EST
Description of problem:
This is an enhancement request to support installing from a hard drive
fully-exploded tree in addition to hard drive ISOs.

Benefits to me:
1. Reduced customer confusion
2. Common install methods (ISO/tree) across every install source
(HD/CD/DVD/FTP/HTTP)
3. Common DVD/HD factory recovery install image
4. HD Kickstart without making ISOs

Drawbacks:
1. Additional complexity in /sbin/loader
Comment 1 Jeremy Katz 2005-01-27 17:45:12 EST
This isn't going to be added back.  It used to exist and was a massive
support problem due to people creating trees improperly.  Similarly,
NFS tree installs are likely to be deprecated as of RHEL5 due to the
same problems.

And your reasoning about common install methods isn't really true. 
eg, ISOs can't be used for HTTP/FTP.  ISOs are the preferred form for
all other install paths.  

Additionally, "HD Kickstart without making ISOs" isn't really true...
you are receiving the OS on ISOs, so you hardly need to make them. 
You have to make the tree, which is much more difficult.
Comment 2 Micah Parrish 2005-01-27 22:20:28 EST
The thing is that we want to deliver the OS in its own partition on
the hard drive, ready to install or reinstall.  It is a lot easier for
us to do that from a tree than from ISOs due to arcanities of our
factory processes that I can't really disclose in a public bug.  I
know it's an odd reason, but Ialso know I'm not the only one who needs
this feature.  See
https://www.redhat.com/archives/kickstart-list/2004-December/msg00007.html.

My other alternative involves starting an http server before
/sbin/loader and doing the install from tree that way.

Note You need to log in before you can comment on or make changes to this bug.