Bug 1464002 - Consume libvirt fixes fox RHEL7.4 [depends on bug 1461303; bug 1470127 - fixed for 7.4.z]
Consume libvirt fixes fox RHEL7.4 [depends on bug 1461303; bug 1470127 - fixe...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
4.20.0
x86_64 Unspecified
high Severity medium (vote)
: ovirt-4.1.7
: 4.19.35
Assigned To: Tal Nisan
Raz Tamir
:
Depends On: 1461303 1504150
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 05:07 EDT by Tal Nisan
Modified: 2017-11-13 07:24 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1461303
Environment:
Last Closed: 2017-11-13 07:24:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: exception+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78899 master MERGED spec: Update libvirt and libvirt-python requirements 2017-10-01 10:54 EDT
oVirt gerrit 82438 ovirt-4.1 MERGED spec: Update libvirt and libvirt-python requirements 2017-10-16 08:08 EDT

  None (edit)
Comment 1 Allon Mureinik 2017-07-03 03:06:53 EDT
The real fix for this problem is in libvirt, via bug 1461303. There are no code changes required from vdsm's side, so simply dnf updating libvirt to get libvirt-3.2.0-12.el7 once it's released will solve the problem.

RHV 4.1.4 will be released *before* this libvirt, so we can't require it there. On the other hand, the original bug occured on an unreleased libvirt build which no customer should ever encounter, so requiring it is a useful safety measure, but not a hard requirement.

Reducing priotiy/severity accordingly.
Comment 2 Allon Mureinik 2017-07-12 04:00:27 EDT
bug 1467826 is also a critical libvirt bug which should be delivered as a 0day errata by libvirt.

We should wait till that is released and require the right libvirt version that contains fixes for both bugs - bug 1461303 and bug 1467826.
Comment 3 Allon Mureinik 2017-08-07 08:31:24 EDT
There's nothing blocking here - customers who just yum update their environments will get these fixes. Having vdsm require them is an additional safety measure, but definitely not a must.

I prefer waiting for CentOS 7.4 instead of uglifying the spec file - pushing out.
Comment 4 Allon Mureinik 2017-10-01 06:07:28 EDT
The underlying issue is fixed by libvirt - this is just to track a failsagfe of requiring it.
Removing alarming keywords and the blocker flag.
Comment 5 Raz Tamir 2017-10-23 15:23:48 EDT
According to comment #4 - verifying

Note You need to log in before you can comment on or make changes to this bug.