Bug 1464003 - Create Hostgroup page does not populate content views
Create Hostgroup page does not populate content views
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Host Group (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 05:08 EDT by Stanislav Tkachenko
Modified: 2017-06-26 08:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 08:41:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (128.92 KB, image/png)
2017-06-22 05:08 EDT, Stanislav Tkachenko
no flags Details

  None (edit)
Description Stanislav Tkachenko 2017-06-22 05:08:07 EDT
Created attachment 1290584 [details]
Screenshot

Description of problem:
I have lifecycle environment with several associated published content views, however when I'm creating new hostgroup with that LCE, content view selectbox is empty. Even `Default Content View` is missing.

Workaround: Save HG without CV, open it again for editing -> CVs are populated and can be selected.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Create and publish at least one content view
2. Check that it is associated with lifecycle environment
3. Navigate to Configure -> Host Groups
4. Press `Create Host Group`
5. Select LCE from p. 2
6. Try to select CV from p. 1

Actual results:
Selectbox is empty during HG create

Expected results:
Selectbox should be populated with CVs associated with selected LCE.


Additional info:
Comment 1 Stanislav Tkachenko 2017-06-22 05:09:48 EDT
Version-Release number of selected component (if applicable):
Satellite 6.3 Snap 3.0:
* satellite-6.3.0-15.0.beta.el7sat.noarch
* foreman-1.15.0-1.el7sat.noarch
* katello-3.4.1-1.el7sat.noarch
Comment 4 Stanislav Tkachenko 2017-06-26 08:41:32 EDT
Works on new build:
* katello-3.4.1-1.el7sat.noarch
* foreman-1.15.1-1.el7sat.noarch
* satellite-6.3.0-16.0.beta.el7sat.noarch

Note You need to log in before you can comment on or make changes to this bug.