Bug 1464011 - Scale up master failed due to undefined variable error
Scale up master failed due to undefined variable error
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Scott Dodson
Wenkai Shi
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 05:32 EDT by Wenkai Shi
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1716 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.6 RPM Release Advisory 2017-08-10 05:02:50 EDT

  None (edit)
Description Wenkai Shi 2017-06-22 05:32:22 EDT
Description of problem:
Scale up master failed due to undefined variable error.

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.122-1.git.0.62fcd88.el7

How reproducible:
100%

Steps to Reproduce:
1. Prepare a HA env
2. Scaleup master
3. 

Actual results:
# ansible-playbook -i inventory -v /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-master/scaleup.yml
...
TASK [openshift_master : set_fact] *********************************************
fatal: [host-8-175-47.host.centralci.eng.rdu2.redhat.com]: FAILED! => {
    "failed": true
}

MSG:

the field 'args' has an invalid value, which appears to include a variable that is undefined. The error was: {{ hostvars[groups.oo_first_master.0].l_clean_install }}: 'dict object' has no attribute 'l_clean_install'

The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_master/tasks/main.yml': line 131, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- set_fact:
  ^ here
...

Expected results:
Scale up succeed.

Additional info:
Comment 1 Wenkai Shi 2017-06-23 06:18:46 EDT
Add TestBlocker keywords, this block all testing relate to scaleup master.
Comment 4 Wenkai Shi 2017-06-28 04:39:44 EDT
Verified with version openshift-ansible-3.6.126.0-1.git.0.f9c47bf.el7, scaleup succeed.
Comment 6 errata-xmlrpc 2017-08-10 01:28:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.