Bug 1464029 - registries configuration in /etc/containers/registries.conf is comments out in RHELAH 7.4 cloud image
registries configuration in /etc/containers/registries.conf is comments out i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Brent Baude
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 06:14 EDT by Joy Pu
Modified: 2017-08-01 20:16 EDT (History)
5 users (show)

See Also:
Fixed In Version: atomic-1.18.1-3.1.git0705b1b
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 20:16:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The registries.conf copied from the image (deleted)
2017-06-22 06:14 EDT, Joy Pu
no flags Details
registries conf file from the image (819 bytes, text/plain)
2017-06-22 06:22 EDT, Joy Pu
no flags Details

  None (edit)
Description Joy Pu 2017-06-22 06:14:13 EDT
Description of problem:

The registeries in /etc/containers/registries.conf is comments out wiht "#" in rhelah 7.4 cloud image. So the registry.access.redhat.com is not added to docker services and docker will try to download image from docker.io instead of registry.access.redhat.com.


Version-Release number of selected component (if applicable):
rpm is broken (Bug 1462979 - /var/lib/rpm setup broken for RHELAH 7.4 cloud image)
so can just get the version from docker version:

# docker version
Client:
 Version:         1.12.6
 API version:     1.24
 Package version: docker-1.12.6-38.1.git6ffd653.el7.x86_64
 Go version:      go1.8.3
 Git commit:      6ffd653/1.12.6
 Built:           Tue Jun 13 13:54:30 2017
 OS/Arch:         linux/amd64

Server:
 Version:         1.12.6
 API version:     1.24
 Package version: docker-1.12.6-38.1.git6ffd653.el7.x86_64
 Go version:      go1.8.3
 Git commit:      6ffd653/1.12.6
 Built:           Tue Jun 13 13:54:30 2017
 OS/Arch:         linux/amd64


ostree status:
# ostree admin status
* rhel-atomic-host c55bf46b4baaee58d637774e8515bc7e88b96e4acf099d8bca39c27757201442.0
    Version: 7.4.0
    origin refspec: rhel-atomic-host:rhel-atomic-host/7/x86_64/standard


image:
rhel-atomic-cloud-7.4.0-6.x86_64.vhd


How reproducible:
100%


Steps to Reproduce:
1. sodu docker pull rhel7
2. sudo docker images and check the image name


Actual results:
image is downloaded from docker.io

Expected results:
image is downloaded from registry.access.redhat.com


Additional info:
Comment 2 Joy Pu 2017-06-22 06:22 EDT
Created attachment 1290626 [details]
registries conf file from the image
Comment 5 Alex Jia 2017-07-05 05:27:22 EDT
[cloud-user@atomic-host-test ~]$ atomic host status
State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                Version: 7.4.0 (2017-06-30 18:37:40)
                 Commit: 8018f95c2f2f38a79e68f174dd5888b53769c0e4adcd89c87a802219091c9d0e
           GPGSignature: 1 signature
                         Signature made Fri 30 Jun 2017 06:59:48 PM UTC using RSA key ID 199E2F91FD431D51
                         Good signature from "Red Hat, Inc. <security@redhat.com>"

[cloud-user@atomic-host-test ~]$ grep -E "^registries:" -A1 /etc/containers/registries.conf
registries:
  - registry.access.redhat.com

[cloud-user@atomic-host-test ~]$ sudo docker pull rhel7
Using default tag: latest
Trying to pull repository registry.access.redhat.com/rhel7 ... 
latest: Pulling from registry.access.redhat.com/rhel7
d55ab3b04d8b: Pull complete 
b94f985aad49: Pull complete 
Digest: sha256:582cb940a6e730dbdffee7cc5e1983522fdeeb3c40bea7373b255a209124cc02
[cloud-user@atomic-host-test ~]$ sudo docker images
REPOSITORY                         TAG                 IMAGE ID            CREATED             SIZE
registry.access.redhat.com/rhel7   latest              93bb76ddeb7a        13 days ago         192.7 MB
Comment 7 errata-xmlrpc 2017-08-01 20:16:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2348

Note You need to log in before you can comment on or make changes to this bug.