Bug 1464039 - NRPE is missing the nrpe-multiline patch (1024 chars limit)
NRPE is missing the nrpe-multiline patch (1024 chars limit)
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: nrpe (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen John Smoogen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 06:22 EDT by Francisco Garcia
Modified: 2017-07-14 17:36 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 17:36:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nrpe-0009-nrpe-multiline.patch (6.65 KB, patch)
2017-06-22 06:22 EDT, Francisco Garcia
no flags Details | Diff
spec of RHEL7-OSP7 nrpe package (11.66 KB, text/x-matlab)
2017-06-22 06:24 EDT, Francisco Garcia
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1348633 None None None 2017-06-22 06:40 EDT

  None (edit)
Description Francisco Garcia 2017-06-22 06:22:43 EDT
Created attachment 1290628 [details]
nrpe-0009-nrpe-multiline.patch

Description of problem:

NRPE is missing the nrpe-multiline patch, which makes it fail when NRPE needs to report > 1024 char messages. 


Version-Release number of selected component (if applicable):

nrpe-2.15-7.el7.src.rpm

Expected results:

Please include attached patch, which was released for RHEL7-OSP7 nrpe package (nrpe-2.15-4.1.el7.src.rpm)
Comment 1 Francisco Garcia 2017-06-22 06:24 EDT
Created attachment 1290629 [details]
spec of RHEL7-OSP7 nrpe package
Comment 2 Stephen John Smoogen 2017-06-22 09:32:27 EDT
Is there a reason the patch was not sent to upstream? If so what is the github ticket number? If not could it be (or are you needing me to do so?)

I don't like blindly attaching patches without knowing they are sent upstream.
Comment 3 Francisco Garcia 2017-06-28 03:08:00 EDT
To recap...

* The issue is already solved in newer NRPE versions (seems 2.16-RC2, but those were never properly tagged in upstream github). https://github.com/NagiosEnterprises/nrpe/issues/32

* The plan is now to bump EPEL NRPE version to something in the 3.x branch.

Stephen, is this right?
Comment 5 Stephen John Smoogen 2017-07-14 17:36:11 EDT
This was fixed a while ago but I messed up a bodhi line so it didn't auto close.

Note You need to log in before you can comment on or make changes to this bug.