Bug 1464100 - Memory disks are not removed on snapshot deletion
Memory disks are not removed on snapshot deletion
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
future
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Tal Nisan
Kevin Alon Goldblatt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 08:26 EDT by Tal Nisan
Modified: 2017-12-22 02:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:49:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78521 master MERGED core: Skip content type checks when removing snapshot memory volume 2017-06-22 11:08 EDT

  None (edit)
Description Tal Nisan 2017-06-22 08:26:32 EDT
Description of problem:
When removing a snapshot (both merge cold and live merge) that contains memory disks the snapshot is removed successfully but the memory disks remain on the storage

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a VM snapshot with memory
2. Remove the snapshot
3.

Actual results:
Snapshot removal succeeds, yet the memory disks remain on the storage

Expected results:
The memory disks are removed along with the snapshot

Additional info:
Comment 1 Kevin Alon Goldblatt 2017-07-27 09:18:06 EDT
Verified with the following code:
----------------------------------------------
ovirt-engine-4.2.0-0.0.master.20170723141021.git463826a.el7.centos.noarch
vdsm-4.20.1-218.git1b7671f.el7.centos.x86_64


Verified with the following scenario:
---------------------------------------------
Steps to Reproduce:
1. Create a VM snapshot with memory
2. Remove the snapshot >>>>> The memory disks are removed along with the snapshot


Moving to VERIFIED
Comment 2 Sandro Bonazzola 2017-12-20 05:49:59 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.