Bug 1464121 - Will you consider an update to 4.1.x?
Will you consider an update to 4.1.x?
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: BackupPC (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Shaw
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 09:20 EDT by Pim Rupert (Lemonbit)
Modified: 2017-11-24 09:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-24 09:54:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pim Rupert (Lemonbit) 2017-06-22 09:20:10 EDT
New updates were released with many welcome enhancements, see http://backuppc.sourceforge.net/BackupPC-4.1.3.html#BackupPC-Introduction

Version 4 is fully backwards compatible with existing version 3 installations. Thus, if the maintainer is willing to update to 4, there are no issues with releasing the updated packages in EPEL. 

Will you consider an update?
Comment 1 Richard Shaw 2017-06-22 11:03:25 EDT
As I have mentioned on the backuppc mailing list, the problem is not that the pool changes are not compatible but that there are configuration changes which an upgrade can not be guaranteed to map correctly breaking someone's installation. 

Another option would be to have a BackupPC4 package for those that want to use it but there are a few problems with that route as well. I don't have a lot of time and the original 3.x version prior to my taking over maintenance violated the Fedora packaging guidelines in a lot of ways. I have made many improvements over time but I still don't believe the package would pass a review today.

Those that want to upgrade may use my COPR which I have kept up to date. 

https://copr.fedorainfracloud.org/coprs/hobbes1069/BackupPC/
Comment 2 Pim Rupert (Lemonbit) 2017-07-03 13:18:21 EDT
I have created an issue upstream (https://github.com/backuppc/backuppc/issues/127). 

Perhaps there are possibilities to ensure the configuration of v3 is also compatible with v4, thus eliminating the need to maintain separate packages.
Comment 3 Richard Shaw 2017-09-18 15:29:13 EDT
Do we need to leave this bug open? My COPR is available for anyone who wishes to update and I will continue to maintain it, but doing major upgrades within a RHEL release is highly discouraged.

Note You need to log in before you can comment on or make changes to this bug.