Bug 1464166 - cancel reboot causes that the next task is not picked up
cancel reboot causes that the next task is not picked up
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiří Dostál
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 10:46 EDT by Pavel Studeník
Modified: 2017-07-14 05:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 05:19:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2017-06-22 10:46:23 EDT
Description of problem:
I plan to restart system and the osad pick this task. I changed opinion and I cancel restarting shutdown -c. But the task still is not finished. Problem is that the next task is not picked up by osad/rhn_check and it is still in queue.

Version-Release number of selected component (if applicable):
rhn-client-tools-2.0.2-11.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. run osad 
2. schedule reboot system
3. shudown -c

Actual results:
after cancel, the following tasks are not picked up

Expected results:
the next tasks are picked up and the task with reboot is cancel/finished
Comment 2 Jiří Dostál 2017-06-23 08:22:59 EDT
Hi,

could you please provide me some more detailed information about steps 2. and 3.? 

2. Did you schedule the reboot using the remote command? What exactly the command was?

3. Did you execute "shutdown -c" directly on the client or via remote command?

Thank you
Comment 3 Pavel Studeník 2017-06-23 08:31:35 EDT
I think that it is same. But steps are:

1) Install osad and start service
2) click to "Schedule System Reboot" (shutdown -r 3)
3) run the command in bash to cancel rebooting: shutdown -c
Comment 5 Pavel Studeník 2017-06-23 09:14:23 EDT
The same problem exists on RHEL 6.
Comment 9 Pavel Studeník 2017-07-13 09:20:30 EDT
The issue is very specific situation. I try to figure out real situation. For example that first person are working on the system and other person set reboot for it. First person sees that the reboot is planned (reboot sends message to wall each minute) and cancels reboot. 

Or (my situation) I choose bad system to reboot and need to quick cancel it.
Comment 12 Jiří Dostál 2017-07-14 05:19:35 EDT
Described case is definitely correct, but in order to keep event handling consistent, we won't do any code change for this BZ. In case you want to cancel pending action, please use API schedule.failSystemAction.
Comment 13 Pavel Studeník 2017-07-14 05:31:06 EDT
I created new bug 1471018 for described issue.

Note You need to log in before you can comment on or make changes to this bug.