Bug 1464176 - [GSS](6.4.z) There is a memory leak due to org.jboss.as.ejb3.remote.ImportedTransactionCache class
[GSS](6.4.z) There is a memory leak due to org.jboss.as.ejb3.remote.ImportedT...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
6.4.15
Unspecified Unspecified
urgent Severity urgent
: CR1
: EAP 6.4.17
Assigned To: Fedor Gavrilov
Jiří Bílek
:
Depends On:
Blocks: 1465072 eap6417-payload
  Show dependency treegraph
 
Reported: 2017-06-22 11:04 EDT by Tom Ross
Modified: 2017-09-06 09:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 09:32:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1378454 None None None 2017-06-22 11:20 EDT

  None (edit)
Description Tom Ross 2017-06-22 11:04:17 EDT
The org.jboss.as.ejb3.remote.ImportedTransactionCache class was added as a result of fix for bz 1378454. This fix was rejected and pulled out but the class was left and now it's causing memory leak since any transactions in hte cache never expire.
Comment 10 Jiří Bílek 2017-08-02 07:52:15 EDT
Verified with EAP 6.4.17.CP.CR3
Comment 11 Petr Penicka 2017-09-06 09:32:24 EDT
Released on 2017-09-05 as part of the EAP 6.4.17 release.

Note You need to log in before you can comment on or make changes to this bug.